aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnumeric/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-10-26 19:58:07 +0800
committervanilla <vanilla@FreeBSD.org>1998-10-26 19:58:07 +0800
commit49ac777054bd1f14b9be3ffd73ca08d58e5aea1e (patch)
tree87e86781cd2855ec06eab39ec7fadbe4b6b61944 /math/gnumeric/Makefile
parent641f38a9af2d67791d828586e4078f38ba11196c (diff)
downloadfreebsd-ports-gnome-49ac777054bd1f14b9be3ffd73ca08d58e5aea1e.tar.gz
freebsd-ports-gnome-49ac777054bd1f14b9be3ffd73ca08d58e5aea1e.tar.zst
freebsd-ports-gnome-49ac777054bd1f14b9be3ffd73ca08d58e5aea1e.zip
Import gnumeric to math.
Reviewed by: asami
Diffstat (limited to 'math/gnumeric/Makefile')
-rw-r--r--math/gnumeric/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
new file mode 100644
index 000000000000..a3194b823dcb
--- /dev/null
+++ b/math/gnumeric/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnumeric
+# Version required: 0.3
+# Date created: 08 October 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= gnumeric-0.3
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
+ ftp://ftp.gnome.org/pub/GNOME/sources/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
+LIB_DEPENDS+= gnome.0:${PORTSDIR}/x11/gnomelibs
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>