aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnuplot/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2007-10-29 07:21:59 +0800
committerglewis <glewis@FreeBSD.org>2007-10-29 07:21:59 +0800
commit7ac74d72d9e8c8ec27847477a1ca6a8028e1c84d (patch)
tree4c70cb023900a582b7269a5bb1a50c629d978ce8 /math/gnuplot/Makefile
parent44dc5ce49eb7ec4c1c3027d155e6e6607c6ed6a1 (diff)
downloadfreebsd-ports-gnome-7ac74d72d9e8c8ec27847477a1ca6a8028e1c84d.tar.gz
freebsd-ports-gnome-7ac74d72d9e8c8ec27847477a1ca6a8028e1c84d.tar.zst
freebsd-ports-gnome-7ac74d72d9e8c8ec27847477a1ca6a8028e1c84d.zip
. Add a TETEX option which allows gnuplot to be compiled without TeTeX.
PR 113313 Submitted by: Tetsuya Uemura <t_uemura@macome.co.jp>
Diffstat (limited to 'math/gnuplot/Makefile')
-rw-r--r--math/gnuplot/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index e2ff73bde2f8..3134458ee8ec 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -16,19 +16,17 @@ COMMENT= A command-driven interactive function plotting program
GNU_CONFIGURE= yes
WANT_WX= yes
-CONFIGURE_ARGS+=--with-kpsexpand \
- --with-lasergnu \
+CONFIGURE_ARGS+=--with-lasergnu \
--with-readline=gnu \
--without-linux-vga \
--without-lisp-files \
--without-tutorial
-BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base
-
OPTIONS= GD "Enable GD support" on \
- GRIDBOX "Use the gridbox optimization for hidden3d" off \
+ GRIDBOX "Use the gridbox optimization for hidden3d" off \
PDF "Enable PDF support" on \
PLOT "Enable plot support" on \
+ TETEX "Search kpsexpand at run-time" on \
THINSPLINES "Enable thin plate splines for grids in dgrid3d" off \
WX "Enable WX support" off
@@ -70,6 +68,14 @@ LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
CONFIGURE_ARGS+= --with-plot=${LOCALBASE}
.endif
+.if defined(WITHOUT_TETEX)
+PLIST_SUB+= TETEX="@comment "
+.else
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base
+CONFIGURE_ARGS+= --with-kpsexpand
+PLIST_SUB+= TETEX=""
+.endif
+
.if defined(WITHOUT_THINSPLINES)
CONFIGURE_ARGS+= --disable-thin-splines
.else
@@ -84,6 +90,10 @@ WX_CONF_ARGS= absolute
.endif
post-patch:
+.if defined(WITHOUT_TETEX)
+ @${REINPLACE_CMD} -e \
+ '/^install:/s/install-am//' ${WRKSRC}/share/LaTeX/Makefile.in
+.endif
@${REINPLACE_CMD} -e \
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in
@${FIND} "${WRKSRC}" -name '*.orig' -delete