aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnuplot
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-11-08 11:47:27 +0800
committerglewis <glewis@FreeBSD.org>2002-11-08 11:47:27 +0800
commit699474a15ff627d1eeaec3b9f9e09e8c632c3b0e (patch)
treeb509786fac62365b17b5d11bdfdef763cc3d1cef /math/gnuplot
parent2adf79396c8dde1af248e07ccc5dab638a2c26b5 (diff)
downloadfreebsd-ports-gnome-699474a15ff627d1eeaec3b9f9e09e8c632c3b0e.tar.gz
freebsd-ports-gnome-699474a15ff627d1eeaec3b9f9e09e8c632c3b0e.tar.zst
freebsd-ports-gnome-699474a15ff627d1eeaec3b9f9e09e8c632c3b0e.zip
(1) Remove dependency on and support for linking with gd. Gnuplot is only
interested in gd for making gifs. gd hasn't done this since around version 1.4 IIRC (we're now at 1.8.4). (2) Detect libpng correctly (this is fixed slightly differently than the PR). PR: 45035 Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com> (2)
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index c76ced06e935..cf46c707ac74 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -13,21 +13,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= chuckr@FreeBSD.org
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
.if !defined(WITHOUT_X11)
USE_XLIB= yes
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/gd"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--includedir=${LOCALBASE}/include/ \
--libdir=${LOCALBASE}/lib \
- --without-linux-vga \
- --with-gd=${LOCALBASE}/lib \
- --with-readline=gnu --with-lasergnu --with-png
+ --without-linux-vga --without-gd \
+ --with-readline=gnu --with-lasergnu --with-png=${LOCALBASE}
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x