aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnuplot
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-07-11 01:43:56 +0800
committerglewis <glewis@FreeBSD.org>2010-07-11 01:43:56 +0800
commit50460a5554212d8b76dea84ae632d8eeebb01f49 (patch)
treeffdc21d157a51aa8a7ec3bfec4a89a8f0f86ddcc /math/gnuplot
parent762043450fba5e3ebdba0dbf1d2b21c3ce625497 (diff)
downloadfreebsd-ports-gnome-50460a5554212d8b76dea84ae632d8eeebb01f49.tar.gz
freebsd-ports-gnome-50460a5554212d8b76dea84ae632d8eeebb01f49.tar.zst
freebsd-ports-gnome-50460a5554212d8b76dea84ae632d8eeebb01f49.zip
. Make the dependency on cairo optional.
. Make the dependency on X11 an actual option. PR: 147679 Submitted by: Dmitry <dmitry2006@yandex.ru>
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 10bf9a6a680d..9c77088851f2 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -13,35 +13,34 @@ MASTER_SITES= SF
MAINTAINER= glewis@FreeBSD.org
COMMENT= A command-driven interactive function plotting program
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-lasergnu \
--with-readline=gnu \
--without-linux-vga \
--without-lisp-files \
--without-tutorial
-USE_GNOME= pango
-OPTIONS= GD "Enable GD support" on \
+OPTIONS= X11 "Enable X11 support" on \
+ GD "Enable GD support" on \
GRIDBOX "Use the gridbox optimization for hidden3d" off \
PDF "Enable PDF support" on \
PLOT "Enable plot support" on \
TETEX "Search kpsexpand at run-time" on \
THINSPLINES "Enable thin plate splines for grids in dgrid3d" off \
- WX "Enable WX support" on
+ WX "Enable WX support" on \
+ CAIRO "Enable CAIRO support" on
MAN1= gnuplot.1 lasergnu.1
INFO= gnuplot
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
-USE_XORG= x11
-PLIST_SUB+= X11=""
-.else
+.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "
+.else
+USE_XORG= x11
+PLIST_SUB+= X11=""
.endif
.if defined(WITHOUT_GD)
@@ -92,6 +91,13 @@ USE_WX= 2.4+
WX_CONF_ARGS= absolute
.endif
+.if defined(WITHOUT_CAIRO)
+CONFIGURE_ARGS+= --without-cairo
+.else
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+USE_GNOME+= pango
+.endif
+
post-patch:
.if defined(WITHOUT_TETEX)
@${REINPLACE_CMD} -e \