aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnuplot
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2013-06-03 09:06:07 +0800
committerglewis <glewis@FreeBSD.org>2013-06-03 09:06:07 +0800
commitde13db1f3345af1acb29ca5f0ed53d7d8750ede9 (patch)
tree905fd682849b263e398b720299376c287910ec7b /math/gnuplot
parented7b108485cd9226fdf2c9b72ca692d34fb06a71 (diff)
downloadfreebsd-ports-gnome-de13db1f3345af1acb29ca5f0ed53d7d8750ede9.tar.gz
freebsd-ports-gnome-de13db1f3345af1acb29ca5f0ed53d7d8750ede9.tar.zst
freebsd-ports-gnome-de13db1f3345af1acb29ca5f0ed53d7d8750ede9.zip
. Update COMMENT and pkg-descr, based on the Official Gnuplot Manual [1]
. Fix conversion to OptionsNG (someone forgot NOPORTDOCS and NOPORTEXAMPLES) [1] . Add EXAMPLES to the list of options [1] . Use standard DESC lines for a few common options (like X11) [1] . Trim version numbers from LIB_DEPENDS [1] . Add DOCS to the list of options . Rename the TETEX option to TEX (since teTeX is no longer the only version of TeX that can be installed) PR: 177452 [1] Submitted by: Kevin Zheng <kevinz5000@gmail.com> [1]
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile39
-rw-r--r--math/gnuplot/pkg-descr47
-rw-r--r--math/gnuplot/pkg-plist4
3 files changed, 37 insertions, 53 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 5a82812b92e3..4008327a5767 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -6,7 +6,7 @@ CATEGORIES= math graphics
MASTER_SITES= SF
MAINTAINER= glewis@FreeBSD.org
-COMMENT= A command-driven interactive function plotting program
+COMMENT= Command-line driven graphing utility
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-lasergnu \
@@ -17,32 +17,28 @@ CONFIGURE_ARGS+=--with-lasergnu \
--with-bitmap-terminals
MAKE_JOBS_SAFE= yes
-OPTIONS_DEFINE= CAIRO GD GRIDBOX PDF PLOT TETEX THINSPLINES WX X11
-CAIRO_DESC= Enable CAIRO support
-GD_DESC= Enable GD support
+OPTIONS_DEFINE= CAIRO DOCS EXAMPLES GD GRIDBOX PDF PLOT TEX THINSPLINES WX X11
GRIDBOX_DESC= Use the gridbox optimization for hidden3d
-PDF_DESC= Enable PDF support
PLOT_DESC= Enable plot support
-TETEX_DESC= Search kpsexpand at run-time
+TEX_DESC= Search kpsexpand at run-time
THINSPLINES_DESC= Enable thin plate splines for grids in dgrid3d
-WX_DESC= Enable WX support
-X11_DESC= Enable X11 support
+WX_DESC= wxWidgets (formerly wxWindows) support
-OPTIONS_DEFAULT=CAIRO GD PDF PLOT TETEX WX X11
+OPTIONS_DEFAULT=CAIRO GD PDF PLOT TEX WX X11
MAN1= gnuplot.1 lasergnu.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCAIRO}
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
USE_GNOME+= pango
.else
CONFIGURE_ARGS+= --without-cairo
.endif
.if ${PORT_OPTIONS:MGD}
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
CONFIGURE_ARGS+= --with-gd=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-gd
@@ -53,7 +49,7 @@ CONFIGURE_ARGS+= --disable-h3d-quadtree --enable-h3d-gridbox
.endif
.if ${PORT_OPTIONS:MPDF}
-LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
+LIB_DEPENDS+= pdf:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-pdf
@@ -61,19 +57,19 @@ CONFIGURE_ARGS+= --without-pdf
.if ${PORT_OPTIONS:MPLOT}
USE_XORG+= xaw xmu xt xext
-LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
+LIB_DEPENDS+= plot:${PORTSDIR}/graphics/plotutils
CONFIGURE_ARGS+= --with-plot=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-plot
.endif
-.if ${PORT_OPTIONS:MTETEX}
+.if ${PORT_OPTIONS:MTEX}
USE_TEX= base texmf latex
CONFIGURE_ARGS+= --with-kpsexpand \
--with-texdir=${LOCALBASE}/share/texmf/tex/latex/gnuplot
-PLIST_SUB+= TETEX=""
+PLIST_SUB+= TEX=""
.else
-PLIST_SUB+= TETEX="@comment "
+PLIST_SUB+= TEX="@comment "
.endif
.if ${PORT_OPTIONS:MTHINSPLINES}
@@ -97,15 +93,15 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PORTEXAMPLES= *
.endif
post-patch:
-.if ! ${PORT_OPTIONS:MTETEX}
+.if ! ${PORT_OPTIONS:MTEX}
@${REINPLACE_CMD} -e \
'/^install:/s/install-am//' ${WRKSRC}/share/LaTeX/Makefile.in
.endif
@@ -113,7 +109,7 @@ post-patch:
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in
@${FIND} "${WRKSRC}" -name '*.orig' -delete
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-build:
@cd ${WRKSRC}/docs && ${MAKE} groff
.endif
@@ -125,7 +121,8 @@ post-install:
cd ${WRKSRC}/demo && ${FIND} . \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
+
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/psdoc
cd ${WRKSRC}/docs && ${INSTALL_DATA} gnuplot.txt gnuplot.dvi \
gnuplot.ps ${DOCSDIR}
diff --git a/math/gnuplot/pkg-descr b/math/gnuplot/pkg-descr
index e941fe1c4a29..9ec6973bc4af 100644
--- a/math/gnuplot/pkg-descr
+++ b/math/gnuplot/pkg-descr
@@ -1,32 +1,19 @@
-Gnuplot is a command-driven interactive function plotting program.
-
-Plots any number of functions, built up of C operators, C library
-functions, and some things C doesn't have like **, sgn(), etc. Also
-support for plotting data files, to compare actual data to
-theoretical curves.
-
-User-defined X and Y ranges (optional auto-ranging), smart axes
-scaling, smart tic marks.
-
-Labelling of X and Y axes.
-
-User-defined constants and functions.
-
-Support through a generalized graphics driver for AED 512, AED 767,
-BBN BitGraph, Commodore Amiga, Roland DXY800A, EEPIC, TeXDraw, EmTeX,
-Epson 60dpi printers, Epson LX-800, Fig, HP2623, HP2648, HP75xx, HPGL,
-HP LaserJet II, Imagen, Iris 4D, MS-DOS Kermit, Kyocera laser printer,
-LaTeX, NEC CP6 pinwriter, PostScript, QMS QUIC, ReGis (VT125 and
-VT2xx), SCO Xenix CGI, Selanar, Star color printer, Tandy DMP-130
-printer, Tek 401x, Tek 410x, Vectrix 384, VT like Tektronix emulator,
-Unix PC (ATT 3b1 or ATT 7300), unixplot, and X11. The PC version
-compiled by Microsoft C supports IBM CGA, EGA, VGA, Hercules, ATT
-6300, and Corona 325 graphics. The PC version compiled by Borland C++
-sup- ports IBM CGA, EGA, MCGA, VGA, Hercules and ATT 6300 graphics.
-Other devices can be added simply, but will require recompiling.
-
-Shell escapes and command line substitution.
-
-Output redirection.
+Gnuplot is a portable multi-platform command-line driven graphing utility. It
+was originally created to allow scientists and students to visualize
+mathematical functions and data interactively, but has grown to support many
+non-interactive uses such as web scripting. It is also used as a plotting engine
+by third-party applications like Octave. Gnuplot has been supported and under
+active development since 1986.
+
+Gnuplot supports many types of plots in either 2D or 3D. It can draw using
+lines, points, boxes, contours, vector fields, surfaces, and various associated
+text. It also supports various specialized plot types. Gnuplot supports many
+different types of output: interactive screen terminals (with mouse and hotkey
+input), direct output to pen plotters or modern printers, and output to many
+file formats (eps, emf, fig, jpeg, LaTeX, pdf, png, postscript, ...). Gnuplot is
+easily extensible to include new output modes. Recent additions include
+interactive terminals based on wxWidgets (usable on multiple platforms), and Qt.
+Mouseable plots embedded in web pages can be generated using the svg or HTML5
+canvas terminal drivers.
WWW: http://www.gnuplot.info/
diff --git a/math/gnuplot/pkg-plist b/math/gnuplot/pkg-plist
index 3af810a98ab2..ea766503deeb 100644
--- a/math/gnuplot/pkg-plist
+++ b/math/gnuplot/pkg-plist
@@ -36,8 +36,8 @@ bin/lasergnu
%%DATADIR%%/4.6/js/previouszoom.png
%%DATADIR%%/4.6/js/textzoom.png
%%DATADIR%%/4.6/lua/gnuplot-tikz.lua
-%%TETEX%%share/texmf/tex/latex/gnuplot/gnuplot.cfg
-%%TETEX%%@dirrm share/texmf/tex/latex/gnuplot
+%%TEX%%share/texmf/tex/latex/gnuplot/gnuplot.cfg
+%%TEX%%@dirrm share/texmf/tex/latex/gnuplot
@dirrm %%DATADIR%%/4.6/lua
@dirrm %%DATADIR%%/4.6/js
%%X11%%@dirrm %%DATADIR%%/4.6/app-defaults