aboutsummaryrefslogtreecommitdiffstats
path: root/math/goblin/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-13 21:59:11 +0800
committerbapt <bapt@FreeBSD.org>2013-07-13 21:59:11 +0800
commita3f389d326af3e90d4fb2545bccfc6befe0e9516 (patch)
tree72a1e1ba94a14f030d77be9bdd4dfce6429ff4cb /math/goblin/Makefile
parent647d906be0245fd573d8cc8d4037d98559592791 (diff)
downloadfreebsd-ports-gnome-a3f389d326af3e90d4fb2545bccfc6befe0e9516.tar.gz
freebsd-ports-gnome-a3f389d326af3e90d4fb2545bccfc6befe0e9516.tar.zst
freebsd-ports-gnome-a3f389d326af3e90d4fb2545bccfc6befe0e9516.zip
Mark jobs unsafe
Diffstat (limited to 'math/goblin/Makefile')
-rw-r--r--math/goblin/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index b7c889f0c541..76ad34ab557c 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= glpk-*
USE_GCC= any
NO_CCACHE= yes
USE_TK= yes
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
@@ -26,6 +26,8 @@ MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
ALL_TARGET= all shared
PLIST_SUB+= VERSION=${PORTVERSION:R}
+MAKE_JOBS_UNSAFE= yes
+
CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/ \
-I${LOCALBASE}/include/tk${TK_VER} ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -ltcl${USE_TCL} -ltk${USE_TK} ${PTHREAD_LIBS}