aboutsummaryrefslogtreecommitdiffstats
path: root/math/goblin
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /math/goblin
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'math/goblin')
-rw-r--r--math/goblin/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index 3857c72f81ad..d7301ac1ff6c 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -8,7 +8,7 @@
PORTNAME= goblin
PORTVERSION= 2.6.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= http://www.math.uni-augsburg.de/~fremuth/goblin.docs/ \
${MASTER_SITE_LOCAL}
@@ -23,6 +23,7 @@ LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
CONFLICTS= ImageMagick-[0-9]* display-*
+USE_XORG= x11
USE_GMAKE= yes
USE_GCC= 3.2
MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
@@ -32,9 +33,9 @@ MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
ALL_TARGET= all goblin.a glpk.a
PLIST_SUB+= VERSION=${PORTVERSION:R}
-CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 \
- -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/ \
+ ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
WISH= ${LOCALBASE}/bin/wish8.3