aboutsummaryrefslogtreecommitdiffstats
path: root/math/grace
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-06-06 03:29:56 +0800
committermiwi <miwi@FreeBSD.org>2010-06-06 03:29:56 +0800
commitd4fd5ec81c1dc1e7c336bb736a56c40a5c2be8bd (patch)
treefc72e1a7ff79042d4ae8e9da28aadf521faa9687 /math/grace
parent250c0b765798473fefe5502c4191e3c3bd43320d (diff)
downloadfreebsd-ports-gnome-d4fd5ec81c1dc1e7c336bb736a56c40a5c2be8bd.tar.gz
freebsd-ports-gnome-d4fd5ec81c1dc1e7c336bb736a56c40a5c2be8bd.tar.zst
freebsd-ports-gnome-d4fd5ec81c1dc1e7c336bb736a56c40a5c2be8bd.zip
- Fix seizes mouse cursor on right-click with Xorg-server 1.7.5
PR: 146383 Submitted by: Tom Russo <russo@bogodyn.org>
Diffstat (limited to 'math/grace')
-rw-r--r--math/grace/Makefile2
-rw-r--r--math/grace/files/patch-src-motifutils.c39
2 files changed, 40 insertions, 1 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index 7bd0a152d0e8..9e4dd2fa50a6 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grace
PORTVERSION= 5.1.22
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math print
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
diff --git a/math/grace/files/patch-src-motifutils.c b/math/grace/files/patch-src-motifutils.c
new file mode 100644
index 000000000000..3e765ae3380e
--- /dev/null
+++ b/math/grace/files/patch-src-motifutils.c
@@ -0,0 +1,39 @@
+
+--- src/motifutils.c.orig 2010-03-15 20:05:12.742336241 -0700
++++ src/motifutils.c 2010-03-15 20:12:53.885346709 -0700
+@@ -118,7 +118,6 @@
+
+ extern unsigned long xvlibcolors[];
+
+-
+ static OptionItem *color_option_items = NULL;
+ static int ncolor_option_items = 0;
+ static OptionStructure **color_selectors = NULL;
+@@ -1621,6 +1620,12 @@
+ graph_popup_menu = xmalloc(sizeof(GraphPopupMenu));
+
+ popup = XmCreatePopupMenu(listp->list, "graphPopupMenu", NULL, 0);
++#if XmVersion >= 2000
++ XtVaSetValues(popup, XmNpopupEnabled, XmPOPUP_DISABLED, NULL);
++ XtUngrabButton(listp->list, AnyButton, AnyModifier);
++#else
++ XtVaSetValues(popup, XmNpopupEnabled, False, NULL);
++#endif
+ graph_popup_menu->popup = popup;
+
+ graph_popup_menu->label_item = CreateMenuLabel(popup, "Selection:");
+@@ -2243,6 +2248,12 @@
+
+ set_popup_menu = xmalloc(sizeof(SetPopupMenu));
+ popup = XmCreatePopupMenu(listp->list, "setPopupMenu", NULL, 0);
++#if XmVersion >= 2000
++ XtVaSetValues(popup, XmNpopupEnabled, XmPOPUP_DISABLED, NULL);
++ XtUngrabButton(listp->list, AnyButton, AnyModifier);
++#else
++ XtVaSetValues(popup, XmNpopupEnabled, False, NULL);
++#endif
+ set_popup_menu->popup = popup;
+
+ set_popup_menu->label_item = CreateMenuLabel(popup, "Selection:");
+
+