aboutsummaryrefslogtreecommitdiffstats
path: root/math/gracetmpl/Makefile
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-08-17 01:27:02 +0800
committermva <mva@FreeBSD.org>2014-08-17 01:27:02 +0800
commit2c2480545ba3740984746e4777c09fd6bddf22f9 (patch)
tree4952aae541eb2be6b5d4cdc010ed7b87c9128b6e /math/gracetmpl/Makefile
parentc4eef03c55c8e082c6f2882003a7e8e46076444b (diff)
downloadfreebsd-ports-gnome-2c2480545ba3740984746e4777c09fd6bddf22f9.tar.gz
freebsd-ports-gnome-2c2480545ba3740984746e4777c09fd6bddf22f9.tar.zst
freebsd-ports-gnome-2c2480545ba3740984746e4777c09fd6bddf22f9.zip
- Enable stagedir support
- Convert USE_PYTHON -> USES=python
Diffstat (limited to 'math/gracetmpl/Makefile')
-rw-r--r--math/gracetmpl/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/math/gracetmpl/Makefile b/math/gracetmpl/Makefile
index eb944a2339f6..0156a12c0037 100644
--- a/math/gracetmpl/Makefile
+++ b/math/gracetmpl/Makefile
@@ -12,8 +12,7 @@ COMMENT= Provide an easy way to use existing grace-files as a template
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
-USE_PYTHON= yes
-USES= gmake tar:bzip2
+USES= gmake python tar:bzip2
MAKE_ARGS= PREFIX="${PREFIX}" \
BIN_PREFIX="${PREFIX}/bin" \
LIB_PREFIX="${PREFIX}/lib" \
@@ -24,13 +23,10 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
CPPFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
CXX="${CXX}"
ALL_TARGET= all pythonwrap
-INSTALL_TARGET= install pythonwrap_install
+INSTALL_TARGET= install
-INSTALLS_EGGINFO= yes
-PYDISTUTILS_PKGNAME= graceTMPL
-PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}/graceTMPL
+PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
-NO_STAGE= yes
post-extract:
@${ECHO_CMD} -n > ${WRKSRC}/Makefile.defs
@@ -38,9 +34,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|/gracetmpl\.a|/libgracetmpl.a|g' ${WRKSRC}/gracetmpl-config.in
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
-.endif
+ @(cd ${INSTALL_WRKSRC}/python; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py \
+ install --root=${STAGEDIR} --prefix=${LOCALBASE} -c -O1)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>