aboutsummaryrefslogtreecommitdiffstats
path: root/math/graphthing
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2012-02-21 21:16:58 +0800
committerarved <arved@FreeBSD.org>2012-02-21 21:16:58 +0800
commit811c15943ce97d6edbebc8aaff6402259e7de0dc (patch)
tree2a8adbc3e7f4bfae30797d260855875083ad8cd6 /math/graphthing
parent84b155f6453f511109b31368376cf097df680c35 (diff)
downloadfreebsd-ports-gnome-811c15943ce97d6edbebc8aaff6402259e7de0dc.tar.gz
freebsd-ports-gnome-811c15943ce97d6edbebc8aaff6402259e7de0dc.tar.zst
freebsd-ports-gnome-811c15943ce97d6edbebc8aaff6402259e7de0dc.zip
Fix build errors with latest bison
Diffstat (limited to 'math/graphthing')
-rw-r--r--math/graphthing/Makefile2
-rw-r--r--math/graphthing/files/patch-src-gt-bison.y20
-rw-r--r--math/graphthing/files/patch-src-lang-bison.y20
3 files changed, 40 insertions, 2 deletions
diff --git a/math/graphthing/Makefile b/math/graphthing/Makefile
index bebf22772552..39c49a084b9c 100644
--- a/math/graphthing/Makefile
+++ b/math/graphthing/Makefile
@@ -18,8 +18,6 @@ COMMENT= A tool that allows you to create, manipulate and study graphs
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= does not compile
-
USE_BZIP2= yes
USE_GNOME= gtk20
USE_BISON= build
diff --git a/math/graphthing/files/patch-src-gt-bison.y b/math/graphthing/files/patch-src-gt-bison.y
new file mode 100644
index 000000000000..550cdfa89f46
--- /dev/null
+++ b/math/graphthing/files/patch-src-gt-bison.y
@@ -0,0 +1,20 @@
+--- src/gt-bison.y.orig 2012-02-21 14:11:30.000000000 +0100
++++ src/gt-bison.y 2012-02-21 14:11:53.000000000 +0100
+@@ -18,7 +18,7 @@
+
+ extern char *yy_gt_text;
+
+-int yy_gt_error (char *s);
++int yy_gt_error (const char *s);
+ int yy_gt_lex (void);
+ %}
+
+@@ -132,7 +132,7 @@
+
+ %%
+
+-int yy_gt_error (char *s)
++int yy_gt_error (const char *s)
+ {
+ fprintf (stderr, "gt-parse: %s in line %i, at symbol \"%s\"\n",
+ s, gt_lineno, yy_gt_text);
diff --git a/math/graphthing/files/patch-src-lang-bison.y b/math/graphthing/files/patch-src-lang-bison.y
new file mode 100644
index 000000000000..6a82bc7268b4
--- /dev/null
+++ b/math/graphthing/files/patch-src-lang-bison.y
@@ -0,0 +1,20 @@
+--- src/lang-bison.y.orig 2012-02-21 14:12:06.000000000 +0100
++++ src/lang-bison.y 2012-02-21 14:12:27.000000000 +0100
+@@ -15,7 +15,7 @@
+
+ std::stack<PhraseBlock *> pbs;
+
+-int yy_lang_error (char *s);
++int yy_lang_error (const char *s);
+ int yy_lang_lex (void);
+ %}
+
+@@ -121,7 +121,7 @@
+
+ extern char *yy_lang_text;
+
+-int yy_lang_error (char *s)
++int yy_lang_error (const char *s)
+ {
+ fprintf (stderr, "lang-parse: %s in line %i, at symbol \"%s\"\n",
+ s, lang_lineno, yy_lang_text);