aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-23 00:22:20 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-23 00:22:20 +0800
commitb52abbab97989989705c754d7ab399842d85c423 (patch)
treef9fd7eec8ae1a161efcb0435b6bbf38ba231f456 /math/gretl/Makefile
parent63ea414884c6decd20549dfc6dbc07b55e26c5b6 (diff)
downloadfreebsd-ports-gnome-b52abbab97989989705c754d7ab399842d85c423.tar.gz
freebsd-ports-gnome-b52abbab97989989705c754d7ab399842d85c423.tar.zst
freebsd-ports-gnome-b52abbab97989989705c754d7ab399842d85c423.zip
add gretl 0.991
Gnu Regression, Econometrics and Time-series Library
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
new file mode 100644
index 000000000000..ed8fe2f7207a
--- /dev/null
+++ b/math/gretl/Makefile
@@ -0,0 +1,56 @@
+# ex:ts=8
+# Ports collection makefile for: gretl
+# Date created: Mar 22, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gretl
+PORTVERSION= 0.991
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+LIB_DEPENDS= gtkextra:${PORTSDIR}/x11-toolkits/gtkextra \
+ xml:${PORTSDIR}/textproc/libxml
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+WANT_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gmake
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= gretl.1 gretl-config.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+.else
+CONFIGURE_ARGS= --disable-gnome
+.endif
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
+ s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
+
+post-patch:
+.for file in gui/gretl.c lib/src/graphing.c
+ @${PERL} -pi -e "s,SIGCLD,SIGCHLD,g" ${WRKSRC}/${file}
+.endfor
+ @${PERL} -pi -e "s,-ldl,,g" ${WRKSRC}/lib/Makefile.in
+.for file in gui/Makefile.in plugin/Makefile.in
+ @${PERL} -pi -e "s,gtk-config,${GTK_CONFIG},g" ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.post.mk>