aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-11-20 21:34:09 +0800
committerijliao <ijliao@FreeBSD.org>2002-11-20 21:34:09 +0800
commit956589b7910973ec72bafdbf2748c89e664ec6e6 (patch)
tree06a6097f8a11e6acde272c9a9ff3fae51475fcf1 /math/gretl/Makefile
parent7be8a4e237cda94d21978e4a60846b14b9d4e54c (diff)
downloadfreebsd-ports-gnome-956589b7910973ec72bafdbf2748c89e664ec6e6.tar.gz
freebsd-ports-gnome-956589b7910973ec72bafdbf2748c89e664ec6e6.tar.zst
freebsd-ports-gnome-956589b7910973ec72bafdbf2748c89e664ec6e6.zip
upgrade to 1.0
PR: 45459 Submitted by: Ports Fury
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile44
1 files changed, 20 insertions, 24 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index dd25124dcd48..8896fb983936 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,47 +7,43 @@
#
PORTNAME= gretl
-PORTVERSION= 0.999
+PORTVERSION= 1.0
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= gnomeole2.0:${PORTSDIR}/devel/libole2 \
- gmp.6:${PORTSDIR}/math/libgmp4 \
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ gnuplot:${PORTSDIR}/math/gnuplot
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
- gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra
-RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+ gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_X_PREFIX= yes
-USE_GNOMENG= yes
-USE_GNOME= gdkpixbuf
-WANT_GNOME= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_GNOMENG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gmake --without-gtk2
+CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake
INSTALLS_SHLIB= yes
MAN1= gretl.1 gretl-config.1
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mgnomeprint}!= ""
-USE_GNOME+= gnomeprint gnomeprefix
-PKGNAMESUFFIX= -gnome
-.else
+.if defined(WITHOUT_GNOME2)
CONFIGURE_ARGS+= --without-gnome
+PLIST_SUB+= GNOME2:="@comment " DATADIR="share"
+.else
+LIB_DEPENDS+= gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui \
+ gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui
+USE_GNOME= gnomeprefix
+PLIST_SUB+= GNOME2:="" DATADIR="share/gnome"
.endif
-pre-patch:
- @${REINPLACE_CMD} -e 's|`glib-config|`\$$GLIB_CONFIG|g ; \
- s|/share/gretl/|/lib/gretl/|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|SIGCLD|SIGCHLD|g' ${WRKSRC}/gui/gretl.c
+pre-configure:
+ @cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/autoconf
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>