aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-04-28 08:58:42 +0800
committerbf <bf@FreeBSD.org>2011-04-28 08:58:42 +0800
commit61f1cab56299d69c097479932693559eafb6cec4 (patch)
tree71910ee9b6f61c62b44e08f2bcc061ef8cb7f40e /math/gretl/Makefile
parent5c656c64d807590202d891908becd00871bb8744 (diff)
downloadfreebsd-ports-gnome-61f1cab56299d69c097479932693559eafb6cec4.tar.gz
freebsd-ports-gnome-61f1cab56299d69c097479932693559eafb6cec4.tar.zst
freebsd-ports-gnome-61f1cab56299d69c097479932693559eafb6cec4.zip
- Update to 1.9.5
- Discard the SSE2 option in favor of a test of MACHINE_CPU
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 5b429ad5ff8e..523a500f14ce 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gretl
-PORTVERSION= 1.9.4
+PORTVERSION= 1.9.5
CATEGORIES= math finance
MASTER_SITES= SF
@@ -28,15 +28,14 @@ CONFIGURE_ARGS = --enable-static --enable-shared --with-gmake --without-gnome
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= LAPACK_LIBS="${LAPACK} ${BLAS}" \
- LDFLAGS="${LDFLAGS}"
+ LDFLAGS="${LDFLAGS}"
MAN1= gretl.1
OPTIONS= ATLAS "Use Atlas for BLAS and LAPACK" off \
GUI "Build the graphical user interface and plugins" on \
NLS "Build with Natural Language Support" on \
ODBC "Build with unixODBC database support" off \
- R "Build with libR support" off \
- SSE2 "Enable build-time auto-detection of SSE2 on i386 for RNG" off
+ R "Build with libR support" off
.include <bsd.port.pre.mk>
@@ -87,7 +86,7 @@ LIB_DEPENDS+= R.0:${PORTSDIR}/math/R
CONFIGURE_ARGS+= --without-libR
.endif
-.if ${ARCH} == "amd64" || (${ARCH} == "i386" && defined(WITH_SSE2))
+.if ${MACHINE_CPU:Msse2}
CONFIGURE_ARGS+= --enable-sse2=yes
.else
CONFIGURE_ARGS+= --enable-sse2=no