aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-02-06 01:28:51 +0800
committerbf <bf@FreeBSD.org>2011-02-06 01:28:51 +0800
commitb7e3d6f61560fe3cd1e06c6bf37c08e0d893514a (patch)
tree104c1fbb8f0ca9a508f5f9e9312032a900887385 /math/gretl/Makefile
parent17657eba263fa2c033f9ea690800b4aecd19a3a0 (diff)
downloadfreebsd-ports-gnome-b7e3d6f61560fe3cd1e06c6bf37c08e0d893514a.tar.gz
freebsd-ports-gnome-b7e3d6f61560fe3cd1e06c6bf37c08e0d893514a.tar.zst
freebsd-ports-gnome-b7e3d6f61560fe3cd1e06c6bf37c08e0d893514a.zip
Update to 1.9.3
Approved by: makc, miwi (mentors, implicit) Feature safe: yes
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile113
1 files changed, 73 insertions, 40 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index c59d4dc7f222..9ae68f97e0ba 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,57 +7,86 @@
#
PORTNAME= gretl
-PORTVERSION= 1.9.1
+PORTVERSION= 1.9.3
CATEGORIES= math finance
MASTER_SITES= SF
MAINTAINER= bf@FreeBSD.org
COMMENT= GNU Regression, Econometrics and Time-series Library
-BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3 \
- mpfr.4:${PORTSDIR}/math/mpfr
-RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
+USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GNOME= gnomehier gtk20 gtksourceview2 libxml2
-USE_GETTEXT= yes
+USE_FORTRAN= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${GCCLIBDIR}"
-CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake --without-gnome
-ALL_TARGET= # empty
USE_LDCONFIG= yes
+WANT_GNOME= yes
-MAN1= gretl.1
+ALL_TARGET= # empty
+CONFIGURE_ARGS = --enable-static --enable-shared --with-gmake --without-gnome
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LAPACK_LIBS="${LAPACK} ${BLAS}" \
+ LDFLAGS="${LDFLAGS}"
-USE_FORTRAN= yes
-CONFIGURE_ENV+= LAPACK_LIBS="${BLAS} ${LAPACK} -l${FORTRANRUNTIME}"
-FORTRANRUNTIME= gfortran
-GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..
+MAN1= gretl.1
+OPTIONS= ATLAS "Use Atlas for BLAS and LAPACK" off \
+ GUI "Build the graphical user interface and plugins" on \
+ NLS "Build with Natural Language Support" on \
+ ODBC "Build with unixODBC database support" off \
+ R "Build with libR support" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha"
-BROKEN= math/lapack appears to be broken on alpha
-.endif
-
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
-.endif
-
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS= -lf77blas -latlas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas \
+ lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
+.if defined(WITH_GUI)
+CONFIGURE_ARGS+= --enable-gui=yes
+USE_GNOME= gnomehier gtksourceview2
+BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+= --enable-gui=no
+PLIST_SUB+= GUI="@comment "
+.endif
+
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --enable-nls=yes
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --enable-nls=no
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITH_ODBC)
+CONFIGURE_ARGS+= --with-odbc
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+PLIST_SUB+= ODBC=""
+.else
+CONFIGURE_ARGS+= --without-odbc
+PLIST_SUB+= ODBC="@comment "
+.endif
+
+.if defined(WITH_R)
+CONFIGURE_ARGS+= --with-libR
+LIB_DEPENDS+= R.0:${PORTSDIR}/math/R
+.else
+CONFIGURE_ARGS+= --without-libR
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|set term png|set term dumb|g' \
${WRKSRC}/configure
@@ -66,29 +95,33 @@ post-patch:
@${REINPLACE_CMD} -e 's|@gnome_prefix@|@prefix@|g' \
${WRKSRC}/gnome/gretl.keys.in
-pre-configure:
- @${DIRNAME} `${F77} -print-libgcc-file-name` > ${WRKSRC}/LIBDIR
-
+.if defined(WITH_GUI)
post-install:
@${MKDIR} ${PREFIX}/share/applications
-.for file in gretl.desktop
- ${INSTALL_DATA} ${WRKSRC}/gnome/${file} ${PREFIX}/share/applications
+.for _file in gretl.desktop
+ ${INSTALL_DATA} ${WRKSRC}/gnome/${_file} ${PREFIX}/share/applications
.endfor
@${MKDIR} ${PREFIX}/share/mime/packages
-.for file in gretl.xml
- ${INSTALL_DATA} ${WRKSRC}/xdg/${file} ${PREFIX}/share/mime/packages
+.for _file in gretl.xml
+ ${INSTALL_DATA} ${WRKSRC}/xdg/${_file} ${PREFIX}/share/mime/packages
.endfor
@${MKDIR} ${PREFIX}/share/mime-info
-.for file in gretl.keys gretl.mime
- ${INSTALL_DATA} ${WRKSRC}/gnome/${file} ${PREFIX}/share/mime-info
+.for _file in gretl.keys gretl.mime
+ ${INSTALL_DATA} ${WRKSRC}/gnome/${_file} ${PREFIX}/share/mime-info
.endfor
@${MKDIR} ${PREFIX}/share/pixmaps
-.for file in gnome-application-x-gretldata.png gnome-application-x-gretlsession.png
- ${INSTALL_DATA} ${WRKSRC}/gnome/${file} ${PREFIX}/share/pixmaps
+.for _file in gnome-application-x-gretldata.png gnome-application-x-gretlsession.png
+ ${INSTALL_DATA} ${WRKSRC}/gnome/${_file} ${PREFIX}/share/pixmaps
.endfor
-.for file in gretl-logo.xpm gretl.xpm
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/${file} ${PREFIX}/share/pixmaps
+.for _file in gretl-logo.xpm gretl.xpm
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/${_file} ${PREFIX}/share/pixmaps
.endfor
@-update-mime-database ${PREFIX}/share/mime
+.endif
+
+regression-test test check: build
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} check)
+
.include <bsd.port.post.mk>