aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-07 11:09:35 +0800
committerrafan <rafan@FreeBSD.org>2006-08-07 11:09:35 +0800
commit159ab93ed548172a6950fa7b6d5b0f087458c94d (patch)
tree9db3309b840bebcb4a0edd5d39044b93ae4c6a9e /math/gretl
parentdf8b1096a726e45329763edd8aca6721b2158989 (diff)
downloadfreebsd-ports-gnome-159ab93ed548172a6950fa7b6d5b0f087458c94d.tar.gz
freebsd-ports-gnome-159ab93ed548172a6950fa7b6d5b0f087458c94d.tar.zst
freebsd-ports-gnome-159ab93ed548172a6950fa7b6d5b0f087458c94d.zip
- Add readline as dependency when it was already installed. The program
will be linked against it anyway, not against a system one. - Fix pkg-plist in non-standard PREFIX cases - Replace deprecated variables - Misc cosmetic fixes PR: ports/101436 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'math/gretl')
-rw-r--r--math/gretl/Makefile9
-rw-r--r--math/gretl/pkg-plist1
2 files changed, 7 insertions, 3 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index eb0f83e36273..f1d5bd88d343 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -24,23 +24,24 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnometarget gtk20 libxml2
+USE_GETTEXT= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DGNUPLOT_PNG" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake
ALL_TARGET= # empty
-INSTALLS_SHLIB= yes
MAN1= gretl.1 gretl-config.1
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha"
-BROKEN= "math/lapack appears to be broken on alpha"
+BROKEN= math/lapack appears to be broken on alpha
.endif
-.if ${OSVERSION} < 500018
+.if ${OSVERSION} < 500018 || exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
@@ -49,8 +50,10 @@ PKGNAMESUFFIX= -gnome
USE_GNOME+= gnomeprefix gtksourceview libgnomeui
GCONF_SCHEMAS= gretl.schemas
DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
+PLIST_SUB+= GNOMEUI=""
.else
CONFIGURE_ARGS+= --without-gnome --without-gtksourceview
+PLIST_SUB+= GNOMEUI="@comment "
.endif
.include <bsd.port.post.mk>
diff --git a/math/gretl/pkg-plist b/math/gretl/pkg-plist
index ca9ca859c1c8..69fed5c55edc 100644
--- a/math/gretl/pkg-plist
+++ b/math/gretl/pkg-plist
@@ -405,6 +405,7 @@ share/locale/tr/LC_MESSAGES/gretl.mo
@dirrm %%DATADIR%%/data/greene
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
+%%GNOMEUI%%@dirrmtry share/gnome
@dirrm lib/gretl-gtk2/data
@dirrm lib/gretl-gtk2
@dirrm include/gretl