aboutsummaryrefslogtreecommitdiffstats
path: root/math/gri/files
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-28 20:36:04 +0800
committerjeh <jeh@FreeBSD.org>2000-10-28 20:36:04 +0800
commit3e5deb59d4914ae345c91a8491d69d6a070ea4b7 (patch)
tree6f5e7788ca00e4ecd350541af878475524d58ad0 /math/gri/files
parentcd092eb903c920b2768010b0729b6c755039cc61 (diff)
downloadfreebsd-ports-gnome-3e5deb59d4914ae345c91a8491d69d6a070ea4b7.tar.gz
freebsd-ports-gnome-3e5deb59d4914ae345c91a8491d69d6a070ea4b7.tar.zst
freebsd-ports-gnome-3e5deb59d4914ae345c91a8491d69d6a070ea4b7.zip
New port: math/gri
Gri is an extensible plotting language for producing scientific graphs PR: 21995 Submitted by: M. L. Dodson <bdodson@scms.utmb.EDU>
Diffstat (limited to 'math/gri/files')
-rw-r--r--math/gri/files/patch-aa33
-rw-r--r--math/gri/files/patch-ab88
2 files changed, 121 insertions, 0 deletions
diff --git a/math/gri/files/patch-aa b/math/gri/files/patch-aa
new file mode 100644
index 000000000000..52288ad15d38
--- /dev/null
+++ b/math/gri/files/patch-aa
@@ -0,0 +1,33 @@
+*** Makefile.in.orig Sun May 7 11:44:07 2000
+--- Makefile.in Sat Sep 23 12:10:29 2000
+***************
+*** 154,167 ****
+ install: all
+ echo "Installing into '$(prefix)' directory"
+ cat startup.msg | sed -e s,VSN,${VERSION}, > tmp
+ $(INSTALL_DATA) tmp $(prefix)/share/gri/startup.msg
+ rm -f tmp
+ $(INSTALL_PROGRAM) gri $(prefix)/bin/gri
+ $(INSTALL_DATA) gri.cmd $(prefix)/share/gri/gri.cmd
+ $(INSTALL_DATA) license.txt $(prefix)/share/gri/license.txt
+! $(INSTALL_PROGRAM) gri_merge $(prefix)/bin/gri_merge
+! $(INSTALL_PROGRAM) gri_unpage $(prefix)/bin/gri_unpage
+! cd doc; prefix=$(prefix) make html-install
+
+ all: force
+ make gri
+--- 154,167 ----
+ install: all
+ echo "Installing into '$(prefix)' directory"
+ cat startup.msg | sed -e s,VSN,${VERSION}, > tmp
++ -@mkdir $(prefix)/share/gri
+ $(INSTALL_DATA) tmp $(prefix)/share/gri/startup.msg
+ rm -f tmp
+ $(INSTALL_PROGRAM) gri $(prefix)/bin/gri
+ $(INSTALL_DATA) gri.cmd $(prefix)/share/gri/gri.cmd
+ $(INSTALL_DATA) license.txt $(prefix)/share/gri/license.txt
+! $(INSTALL_DATA) gri_merge $(prefix)/bin/gri_merge
+! $(INSTALL_DATA) gri_unpage $(prefix)/bin/gri_unpage
+
+ all: force
+ make gri
diff --git a/math/gri/files/patch-ab b/math/gri/files/patch-ab
new file mode 100644
index 000000000000..8bcb5be93f05
--- /dev/null
+++ b/math/gri/files/patch-ab
@@ -0,0 +1,88 @@
+*** doc/Makefile.orig Sun May 7 11:44:08 2000
+--- doc/Makefile Sat Sep 23 12:49:29 2000
+***************
+*** 1,6 ****
+ # Makefile for Gri documentation files.
+
+! GRI_DIR = /opt/gri
+ DEST_BIN = /doc/info
+ RM = rm -f
+ REFCARD = refcard
+--- 1,6 ----
+ # Makefile for Gri documentation files.
+
+! GRI_DIR = $(PREFIX)/share/doc/gri
+ DEST_BIN = /doc/info
+ RM = rm -f
+ REFCARD = refcard
+***************
+*** 11,22 ****
+ FORCE:
+
+ all:
+- make info
+ make html
+
+! install:
+! make info-install
+! make html-install
+
+ read:
+ chmod a+r Makefile
+--- 11,27 ----
+ FORCE:
+
+ all:
+ make html
+
+! # make info
+! # make html
+!
+! man-install:
+! gzip -nfc -9 gri-manpage.1 > gri.1.gz
+! ${INSTALL_MAN} gri.1.gz ${PREFIX}/man/man1
+!
+! # make info-install
+! # make html-install
+
+ read:
+ chmod a+r Makefile
+***************
+*** 48,69 ****
+ perl archive-to-html.pl > Newsgroup.html
+
+ html-install:
+! # GRI_DIR = /opt/gri
+! if test ! -d $(GRI_DIR) ; then mkdir -m 755 -p $(GRI_DIR) ; fi
+! if test ! -d $(GRI_DIR)/doc ; then mkdir -m 755 -p $(GRI_DIR)/doc ; fi
+! if test ! -d $(GRI_DIR)/doc/html ; then mkdir -m 755 -p $(GRI_DIR)/doc/html ; fi
+! if test ! -d $(GRI_DIR)/doc/html/examples ; then mkdir -m 755 -p $(GRI_DIR)/doc/html/examples ; fi
+! if test ! -d $(GRI_DIR)/doc/html/resources ; then mkdir -m 755 -p $(GRI_DIR)/doc/html/resources ; fi
+! -cp ./resources/*.gif $(GRI_DIR)/doc/html/resources
+! -chmod a+r $(GRI_DIR)/doc/html/resources/*
+! -cp ./examples/* $(GRI_DIR)/doc/html/examples
+! -chmod a+r $(GRI_DIR)/doc/html/examples/*
+! -cp ./*.html $(GRI_DIR)/doc/html
+! -cp ./resources/logo.ps $(GRI_DIR)/doc/html/resources
+! -cp ./resources/logo.gif $(GRI_DIR)/doc/html/resources
+! -cp ./resources/logo.gri $(GRI_DIR)/doc/html/resources
+ -chmod a+r $(GRI_DIR)/*
+- -make html-clean
+
+ html-clean:
+ -cp FAQ.html save
+--- 53,66 ----
+ perl archive-to-html.pl > Newsgroup.html
+
+ html-install:
+! -cp ./resources/*.gif $(GRI_DIR)/html/resources
+! -chmod a+r $(GRI_DIR)/html/resources/*
+! -cp ./examples/* $(GRI_DIR)/html/examples
+! -chmod a+r $(GRI_DIR)/html/examples/*
+! -cp ./*.html $(GRI_DIR)/html
+! -cp ./resources/logo.eps $(GRI_DIR)/html/resources
+! -cp ./resources/logo.gif $(GRI_DIR)/html/resources
+ -chmod a+r $(GRI_DIR)/*
+
+ html-clean:
+ -cp FAQ.html save