aboutsummaryrefslogtreecommitdiffstats
path: root/math/guppi
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /math/guppi
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'math/guppi')
-rw-r--r--math/guppi/Makefile10
-rw-r--r--math/guppi/files/patch-Makefile.in16
2 files changed, 9 insertions, 17 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 82488c817e93..7f40bb5df4d4 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
USE_PYTHON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -36,11 +37,8 @@ PLIST_SUB= VERSION="${PORTVERSION}"
post-extract:
@cd ${PORTSDIR}/math/gnumeric && ${MAKE} patch
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/math/guppi/files/patch-Makefile.in b/math/guppi/files/patch-Makefile.in
index b8891ef7e9f9..de132b24be95 100644
--- a/math/guppi/files/patch-Makefile.in
+++ b/math/guppi/files/patch-Makefile.in
@@ -1,24 +1,18 @@
$FreeBSD$
---- Makefile.in.orig Fri Nov 23 18:19:00 2001
-+++ Makefile.in Fri Nov 23 18:19:44 2001
-@@ -205,12 +205,12 @@
+--- Makefile.in.orig Thu Jul 11 04:03:22 2002
++++ Makefile.in Thu Jul 11 04:04:37 2002
+@@ -197,7 +197,7 @@
#appdir = $(datadir)/apps/Applications
#app_DATA = guppi.desktop
-confexecdir = $(libdir)
-+confexecdir = $(prefix)/etc
++confexecdir = $(sysconfdir)
confexec_DATA = libguppiConf.sh
CLEANFILES = libguppiConf.sh xml-i18n-extract xml-i18n-merge xml-i18n-update
-
--aclocaldir = $(datadir)/aclocal
-+aclocaldir = $(prefix)/share/aclocal
- aclocal_DATA = libguppi.m4
-
- EXTRA_DIST = ChangeLog README AUTHORS NEWS BIBLIOGRAPHY libguppiConf.sh.in libguppi.m4 xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in
-@@ -545,10 +545,10 @@
+@@ -537,10 +537,10 @@
libguppiConf.sh: libguppiConf.sh.in Makefile