aboutsummaryrefslogtreecommitdiffstats
path: root/math/ised
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-21 20:55:26 +0800
committermiwi <miwi@FreeBSD.org>2010-03-21 20:55:26 +0800
commitbb2e821358ff88ea8a6f0d5d698b6faa0633f4ee (patch)
tree89689140bcbe08e73d63c55ee41b5867a004978a /math/ised
parentdbc447785336f1cd95b685e33b9cb6954fba3490 (diff)
downloadfreebsd-ports-gnome-bb2e821358ff88ea8a6f0d5d698b6faa0633f4ee.tar.gz
freebsd-ports-gnome-bb2e821358ff88ea8a6f0d5d698b6faa0633f4ee.tar.zst
freebsd-ports-gnome-bb2e821358ff88ea8a6f0d5d698b6faa0633f4ee.zip
ised is a command-line tool for generating number sequences and
arithmetic evaluation. Unlike big gui-based software (e.g. Mathematica, Derive, Matlab, Octave,...) it is intended for use in shell scripting, together with gnu core utilities. Its main advantage is that all functions are generalized to operate on one-dimensional arrays. It can be used for loop indexing (much like seq), line-by-line arithmetic processing of files, floating point math for shells that don't support it natively, or interactively, as extended calculator. WWW: http://ised.sourceforge.net PR: ports/144914 Submitted by: Charlie Kester <corky1951 at comcast.net>
Diffstat (limited to 'math/ised')
-rw-r--r--math/ised/Makefile32
-rw-r--r--math/ised/distinfo3
-rw-r--r--math/ised/pkg-descr12
3 files changed, 47 insertions, 0 deletions
diff --git a/math/ised/Makefile b/math/ised/Makefile
new file mode 100644
index 000000000000..d93f7c02b031
--- /dev/null
+++ b/math/ised/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: ised
+# Date created: 20 Mar 2010
+# Whom: Charlie Kester <corky1951@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ised
+PORTVERSION= 2.2.2
+CATEGORIES= math
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= A tool for generating number sequences and arithmetic evaluation
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= ${PORTNAME}.1
+.endif
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ised/distinfo b/math/ised/distinfo
new file mode 100644
index 000000000000..9f9cad286bc1
--- /dev/null
+++ b/math/ised/distinfo
@@ -0,0 +1,3 @@
+MD5 (ised-2.2.2.tar.bz2) = 441fe6f5228f3d9b0549f88b5b3776bb
+SHA256 (ised-2.2.2.tar.bz2) = b6d2c6ad218cca1c2ccfc2d4cee570fcb41cc09b824de15992630abdb46561d9
+SIZE (ised-2.2.2.tar.bz2) = 99694
diff --git a/math/ised/pkg-descr b/math/ised/pkg-descr
new file mode 100644
index 000000000000..cd11b66bcd2b
--- /dev/null
+++ b/math/ised/pkg-descr
@@ -0,0 +1,12 @@
+ised is a command-line tool for generating number sequences and
+arithmetic evaluation. Unlike big gui-based software (e.g. Mathematica,
+Derive, Matlab, Octave,...) it is intended for use in shell scripting,
+together with gnu core utilities.
+
+Its main advantage is that all functions are generalized to operate
+on one-dimensional arrays. It can be used for loop indexing (much
+like seq), line-by-line arithmetic processing of files, floating
+point math for shells that don't support it natively, or interactively,
+as extended calculator.
+
+WWW: http://ised.sourceforge.net