aboutsummaryrefslogtreecommitdiffstats
path: root/math/jacal/Makefile
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2002-03-16 22:32:05 +0800
committermarkm <markm@FreeBSD.org>2002-03-16 22:32:05 +0800
commit7a3c2b36a5785b55555974e4761b367b0bb51c1d (patch)
treee5c9f539101b85035b11e7e200a41a250adc9713 /math/jacal/Makefile
parent8d09ff76d1067af77e9e8427b4424797f217341e (diff)
downloadfreebsd-ports-gnome-7a3c2b36a5785b55555974e4761b367b0bb51c1d.tar.gz
freebsd-ports-gnome-7a3c2b36a5785b55555974e4761b367b0bb51c1d.tar.zst
freebsd-ports-gnome-7a3c2b36a5785b55555974e4761b367b0bb51c1d.zip
Add jacal - a Symbolic Mathematics package, written in Scheme.
Diffstat (limited to 'math/jacal/Makefile')
-rw-r--r--math/jacal/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/jacal/Makefile b/math/jacal/Makefile
new file mode 100644
index 000000000000..a318174ae2c5
--- /dev/null
+++ b/math/jacal/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Jacal
+# Date created: Sat Mar 16 2002
+# Whom: Mark R V Murray <markm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jacal
+PORTVERSION= 1b2
+CATEGORIES= math
+MASTER_SITES= http://swissnet.ai.mit.edu/ftpdir/scm/
+DISTNAME= jacal1b2
+
+MAINTAINER= markm@FreeBSD.org
+
+RUN_DEPENDS= scm:${PORTSDIR}/lang/scm
+
+WRKSRC= ${WRKDIR}/jacal
+
+USE_ZIP= yes
+USE_GMAKE= yes
+NO_BUILD= yes
+
+MAN1= jacal.1
+
+do-configure:
+ cd ${WRKSRC}; \
+ find . -type f -exec perl -spi -e 's|%%PREFIX%%|${PREFIX}|' {} ';'
+
+.include <bsd.port.mk>