aboutsummaryrefslogtreecommitdiffstats
path: root/math/jakarta-commons-math
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /math/jakarta-commons-math
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'math/jakarta-commons-math')
-rw-r--r--math/jakarta-commons-math/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index 0c8411cb29f5..1b4e0181590a 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -18,9 +18,10 @@ COMMENT= Java library of self-contained mathematics and statistics components
LICENSE= APACHE20
+USE_ANT= yes
USE_JAVA= yes
JAVA_VERSION= 1.6 1.7
-USE_ANT= yes
+USE_LOCALE= en_US.ISO8859-1
ALL_TARGET= jar
MAKE_ARGS= -Dlibdir=${WRKDIR} -Dnoget=true
@@ -31,8 +32,6 @@ PLIST_FILES+= %%JAVAJARDIR%%/${DESTJARFILE}
OPTIONS_DEFINE= DOCS
-MAKE_ENV= LANG=en_US.ISO8859-1
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}