aboutsummaryrefslogtreecommitdiffstats
path: root/math/jama/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-03 13:40:15 +0800
committerwill <will@FreeBSD.org>2003-06-03 13:40:15 +0800
commit7efe87f7a01e717cef4ff6b59bde9489c457fb97 (patch)
treef54bcc39bd2697e0489053ce72b3299ef2f8a765 /math/jama/Makefile
parentfb3a9a17fa697a87457d95cb1dc96966d359cd72 (diff)
downloadfreebsd-ports-gnome-7efe87f7a01e717cef4ff6b59bde9489c457fb97.tar.gz
freebsd-ports-gnome-7efe87f7a01e717cef4ff6b59bde9489c457fb97.tar.zst
freebsd-ports-gnome-7efe87f7a01e717cef4ff6b59bde9489c457fb97.zip
Add jama 1.2.1, Java-like Matrix C++ Templates.
PR: 52850 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Diffstat (limited to 'math/jama/Makefile')
-rw-r--r--math/jama/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/math/jama/Makefile b/math/jama/Makefile
new file mode 100644
index 000000000000..b84e3aac410e
--- /dev/null
+++ b/math/jama/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: jama
+# Date created: May 15, 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jama
+PORTVERSION= 1.2.1
+CATEGORIES= math devel
+MASTER_SITES= http://math.nist.gov/tnt/
+DISTNAME= ${PORTNAME}121src
+.ifndef NOPORTDOCS
+DISTFILES=${DISTNAME}${EXTRACT_SUFX} jama102doc.zip
+.endif
+DIST_SUBDIR= tnt
+EXTRACT_ONLY=
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Java-like Matrix C++ Templates
+
+BUILD_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt
+RUN_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/tnt
+ ${EXTRACT_CMD} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ -d ${PREFIX}/include/tnt
+.ifndef NOPORTDOCS
+ ${MKDIR} ${PREFIX}/share/doc
+ ${EXTRACT_CMD} ${DISTDIR}/${DIST_SUBDIR}/jama102doc \
+ -d ${PREFIX}/share/doc
+ ${MV} ${PREFIX}/share/doc/doxygen ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>