aboutsummaryrefslogtreecommitdiffstats
path: root/math/lapack/scripts
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2006-02-08 05:25:05 +0800
committerjmz <jmz@FreeBSD.org>2006-02-08 05:25:05 +0800
commit2b20a54c9c08e7a4d28e5d2dfa5664c5cb7cd16a (patch)
tree04220a7a0e108fec6a8d9d2375c841b4f5ce701c /math/lapack/scripts
parent39c8b4e21ebe9eeeb86cb1024ae17e5344441fc2 (diff)
downloadfreebsd-ports-gnome-2b20a54c9c08e7a4d28e5d2dfa5664c5cb7cd16a.tar.gz
freebsd-ports-gnome-2b20a54c9c08e7a4d28e5d2dfa5664c5cb7cd16a.tar.zst
freebsd-ports-gnome-2b20a54c9c08e7a4d28e5d2dfa5664c5cb7cd16a.zip
Don't build the included blas library and add a dependency on math/blas.
This port conflicts with math/atlas. Problem pointed out by: Pedro F. Giffuni
Diffstat (limited to 'math/lapack/scripts')
-rw-r--r--math/lapack/scripts/configure52
1 files changed, 0 insertions, 52 deletions
diff --git a/math/lapack/scripts/configure b/math/lapack/scripts/configure
index c11a54624c46..207c20371ff3 100644
--- a/math/lapack/scripts/configure
+++ b/math/lapack/scripts/configure
@@ -4,58 +4,6 @@ else
LIBG2C=g2c
fi
-cd $WRKSRC/BLAS/SRC || exit 1
-
-mv Makefile Makefile.old
-
-cat >Makefile <<END
-LIB= blas
-SHLIB_MAJOR= 2
-SHLIB_MINOR= 0
-
-LDADD= -l${LIBG2C}
-
-END
-cat >>Makefile <<'END'
-SBLAS1= isamax.f sasum.f saxpy.f scopy.f sdot.f snrm2.f \
- srot.f srotg.f sscal.f sswap.f
-CBLAS1 = scasum.f scnrm2.f icamax.f caxpy.f ccopy.f \
- cdotc.f cdotu.f csscal.f crotg.f cscal.f cswap.f
-DBLAS1 = idamax.f dasum.f daxpy.f dcopy.f ddot.f dnrm2.f \
- drot.f drotg.f dscal.f dswap.f
-ZBLAS1 = dcabs1.f dzasum.f dznrm2.f izamax.f zaxpy.f zcopy.f \
- zdotc.f zdotu.f zdscal.f zrotg.f zscal.f zswap.f
-
-ALLBLAS = lsame.f xerbla.f
-
-SBLAS2 = sgemv.f sgbmv.f ssymv.f ssbmv.f sspmv.f \
- strmv.f stbmv.f stpmv.f strsv.f stbsv.f stpsv.f \
- sger.f ssyr.f sspr.f ssyr2.f sspr2.f
-CBLAS2 = cgemv.f cgbmv.f chemv.f chbmv.f chpmv.f \
- ctrmv.f ctbmv.f ctpmv.f ctrsv.f ctbsv.f ctpsv.f \
- cgerc.f cgeru.f cher.f chpr.f cher2.f chpr2.f
-DBLAS2 = dgemv.f dgbmv.f dsymv.f dsbmv.f dspmv.f \
- dtrmv.f dtbmv.f dtpmv.f dtrsv.f dtbsv.f dtpsv.f \
- dger.f dsyr.f dspr.f dsyr2.f dspr2.f
-ZBLAS2 = zgemv.f zgbmv.f zhemv.f zhbmv.f zhpmv.f \
- ztrmv.f ztbmv.f ztpmv.f ztrsv.f ztbsv.f ztpsv.f \
- zgerc.f zgeru.f zher.f zhpr.f zher2.f zhpr2.f
-
-SBLAS3 = sgemm.f ssymm.f ssyrk.f ssyr2k.f strmm.f strsm.f
-CBLAS3 = cgemm.f csymm.f csyrk.f csyr2k.f ctrmm.f ctrsm.f \
- chemm.f cherk.f cher2k.f
-DBLAS3 = dgemm.f dsymm.f dsyrk.f dsyr2k.f dtrmm.f dtrsm.f
-ZBLAS3 = zgemm.f zsymm.f zsyrk.f zsyr2k.f ztrmm.f ztrsm.f \
- zhemm.f zherk.f zher2k.f
-
-SRCS= $(ALLBLAS) $(SBLAS1) $(SBLAS2) $(SBLAS3) \
- $(DBLAS1) $(DBLAS2) $(DBLAS3) \
- $(CBLAS1) $(CBLAS2) $(CBLAS3) \
- $(ZBLAS1) $(ZBLAS2) $(ZBLAS3)
-
-.include <bsd.lib.mk>
-END
-
cd $WRKSRC/SRC || exit 1
mv Makefile Makefile.old