aboutsummaryrefslogtreecommitdiffstats
path: root/math/lapack95/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-08-29 15:49:57 +0800
committermaho <maho@FreeBSD.org>2004-08-29 15:49:57 +0800
commitbed82e58152162f4896cf5406611385b13a4d7d5 (patch)
tree18df51d321a81887c78baeaf932a2edd2de0fe74 /math/lapack95/Makefile
parent6e6d6fbc437b11e934afb4d42466775286ae29ce (diff)
downloadfreebsd-ports-gnome-bed82e58152162f4896cf5406611385b13a4d7d5.tar.gz
freebsd-ports-gnome-bed82e58152162f4896cf5406611385b13a4d7d5.tar.zst
freebsd-ports-gnome-bed82e58152162f4896cf5406611385b13a4d7d5.zip
Add New port lapack95
LAPACK95 is a Fortran 95 interface to the Fortran 77 LAPACK library. It improves upon the original user-interface to the LAPACK package, taking advantage of the considerable simplifications which Fortran 95 allows. The design of LAPACK95 exploits assumed-shape arrays, optional arguments, and generic interfaces. The Fortran 95 interface has been implemented by writing Fortran 95 ``wrappers'' to call existing routines from the LAPACK package. This interface can persist unchanged even if the underlying Fortran 77 LAPACK code is rewritten to take advantage of the new features of Fortran 95.
Diffstat (limited to 'math/lapack95/Makefile')
-rw-r--r--math/lapack95/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/math/lapack95/Makefile b/math/lapack95/Makefile
new file mode 100644
index 000000000000..04486545bcc4
--- /dev/null
+++ b/math/lapack95/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: lapack95
+# Date created: 5 Feb 2003
+# Whom: NAKATA, Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lapack95
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.netlib.org/lapack95/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= lapack95
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= LAPACK95, Fortran90/95 wrapper for LAPACK
+
+BUILD_DEPENDS= ${LOCALBASE}/intel_fc_80/bin/ifort:${PORTSDIR}/lang/ifc
+LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+
+WRKSRC= ${WRKDIR}/LAPACK95
+FC= ${LOCALBASE}/intel_fc_80/bin/ifort
+FORTRAN_FIXED=
+FORTRAN_FREE= -free
+FFOPTFLAGS= -O3 -tpp7 -xKW -Vaxlib
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%FC%%,${FC},g ; \
+ s,%%FORTRAN_FIXED%%,${FORTRAN_FIXED},g ; \
+ s,%%FORTRAN_FREE%%,${FORTRAN_FREE},g ; \
+ s,%%FFOPTFLAGS%%,${FFOPTFLAGS},g ; \
+ s,%%LOCALBASE%%,${LOCALBASE},g' \
+ ${WRKSRC}/make.inc
+do-build:
+ cd ${WRKSRC}/SRC; ${MAKE} single_double_complex_dcomplex
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lapack95.a ${PREFIX}/lib/liblapack95.a
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}/EXAMPLES1
+ @${MKDIR} ${EXAMPLESDIR}/EXAMPLES2
+ ${CP} ${WRKSRC}/make.inc ${EXAMPLESDIR}
+ ${TAR} cf - -C ${WRKSRC}/EXAMPLES1 . | ${TAR} xf - -C ${EXAMPLESDIR}/EXAMPLES1
+ ${TAR} cf - -C ${WRKSRC}/EXAMPLES2 . | ${TAR} xf - -C ${EXAMPLESDIR}/EXAMPLES2
+
+.include <bsd.port.mk>