aboutsummaryrefslogtreecommitdiffstats
path: root/math/libgmp4/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-03-03 01:56:58 +0800
committernaddy <naddy@FreeBSD.org>2003-03-03 01:56:58 +0800
commitf9fcbbb539543d391e3878f5e3ed2682d4f09cf9 (patch)
treea7c01a5cc31e13fcddbaa9fa5112688068c39fde /math/libgmp4/Makefile
parente310e0de1a33c9343b7663baec975b6a63ea281e (diff)
downloadfreebsd-ports-gnome-f9fcbbb539543d391e3878f5e3ed2682d4f09cf9.tar.gz
freebsd-ports-gnome-f9fcbbb539543d391e3878f5e3ed2682d4f09cf9.tar.zst
freebsd-ports-gnome-f9fcbbb539543d391e3878f5e3ed2682d4f09cf9.zip
Enable building of MPFR, a C library for multiple-precision floating-point
computations with exact rounding, in GMP. Take maintainership. PR: 48640 Submitted by: Alex Dupre <sysadmin@alexdupre.com>
Diffstat (limited to 'math/libgmp4/Makefile')
-rw-r--r--math/libgmp4/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/libgmp4/Makefile b/math/libgmp4/Makefile
index 41f512d49817..bc4cdb37bdab 100644
--- a/math/libgmp4/Makefile
+++ b/math/libgmp4/Makefile
@@ -8,22 +8,22 @@
PORTNAME= libgmp
PORTVERSION= 4.1.2
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gmp
DISTNAME= gmp-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sysadmin@alexdupre.com
COMMENT= A free library for arbitrary precision arithmetic
USE_REINPLACE= yes
USE_LIBTOOL= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-cxx
+CONFIGURE_ARGS= --enable-cxx --enable-mpfr
INSTALLS_SHLIB= yes
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|--tag=CC||g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|--tag=CC||g'
.include <bsd.port.mk>