aboutsummaryrefslogtreecommitdiffstats
path: root/math/libqalculate
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-06-07 17:01:36 +0800
committerpav <pav@FreeBSD.org>2005-06-07 17:01:36 +0800
commita7496bc4418dad19ffd838e5cb99a1a04e899792 (patch)
tree6682aabc072011122a78303356fc2d8c6fb12c2b /math/libqalculate
parent20fa2a7f1789f2895848a892dd55c99dc2d76f34 (diff)
downloadfreebsd-ports-gnome-a7496bc4418dad19ffd838e5cb99a1a04e899792.tar.gz
freebsd-ports-gnome-a7496bc4418dad19ffd838e5cb99a1a04e899792.tar.zst
freebsd-ports-gnome-a7496bc4418dad19ffd838e5cb99a1a04e899792.zip
- Update qalculate to 0.8.0, which splits out libqalculate
PR: ports/81832 Submitted by: Sergey Akifyev <asa@agava.com> (maintainer)
Diffstat (limited to 'math/libqalculate')
-rw-r--r--math/libqalculate/Makefile31
-rw-r--r--math/libqalculate/distinfo2
-rw-r--r--math/libqalculate/files/patch-libqalculate-Calculator.cc11
-rw-r--r--math/libqalculate/files/patch-src-Makefile.in11
-rw-r--r--math/libqalculate/files/patch-src-qalc.cc11
-rw-r--r--math/libqalculate/pkg-descr6
-rw-r--r--math/libqalculate/pkg-plist29
7 files changed, 101 insertions, 0 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
new file mode 100644
index 000000000000..1975288419aa
--- /dev/null
+++ b/math/libqalculate/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libqalculate
+# Date created: 03 June 2004
+# Whom: Sergey Akifyev <asa@agava.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libqalculate
+PORTVERSION= 0.8.0
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= qalculate
+
+MAINTAINER= asa@agava.com
+COMMENT= Very powerful GUI calculator for GNOME (backend library)
+
+LIB_DEPENDS= cln.3:${PORTSDIR}/math/cln
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_INC_LIBTOOL_VER=15
+USE_GNOME= intlhack lthack pkgconfig gnomehack glib20 libxml2
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not configure"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/libqalculate/distinfo b/math/libqalculate/distinfo
new file mode 100644
index 000000000000..3bb70373a693
--- /dev/null
+++ b/math/libqalculate/distinfo
@@ -0,0 +1,2 @@
+MD5 (libqalculate-0.8.0.tar.gz) = c3b63fa34093e519d9ff55a590713620
+SIZE (libqalculate-0.8.0.tar.gz) = 665416
diff --git a/math/libqalculate/files/patch-libqalculate-Calculator.cc b/math/libqalculate/files/patch-libqalculate-Calculator.cc
new file mode 100644
index 000000000000..fec6d7893e6d
--- /dev/null
+++ b/math/libqalculate/files/patch-libqalculate-Calculator.cc
@@ -0,0 +1,11 @@
+--- libqalculate/Calculator.cc.orig Fri Jun 3 12:25:49 2005
++++ libqalculate/Calculator.cc Fri Jun 3 12:25:59 2005
+@@ -33,7 +33,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <dirent.h>
+-#include <wait.h>
++#include <sys/wait.h>
+ #include <queue>
+ #include <glib.h>
+
diff --git a/math/libqalculate/files/patch-src-Makefile.in b/math/libqalculate/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..34cd1b4a1820
--- /dev/null
+++ b/math/libqalculate/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Tue Jun 7 10:42:56 2005
++++ src/Makefile.in Tue Jun 7 10:44:51 2005
+@@ -530,7 +530,7 @@
+
+
+ install-exec-local:
+- cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
++# cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/math/libqalculate/files/patch-src-qalc.cc b/math/libqalculate/files/patch-src-qalc.cc
new file mode 100644
index 000000000000..f5e93c171d5b
--- /dev/null
+++ b/math/libqalculate/files/patch-src-qalc.cc
@@ -0,0 +1,11 @@
+--- src/qalc.cc.orig Fri Jun 3 12:51:31 2005
++++ src/qalc.cc Fri Jun 3 12:51:45 2005
+@@ -16,7 +16,7 @@
+ #include <time.h>
+ #include <pthread.h>
+ #include <dirent.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <vector>
+ #include <glib.h>
diff --git a/math/libqalculate/pkg-descr b/math/libqalculate/pkg-descr
new file mode 100644
index 000000000000..45ee2936fc83
--- /dev/null
+++ b/math/libqalculate/pkg-descr
@@ -0,0 +1,6 @@
+Qalculate! is a multi-purpose desktop calculator. It is small and simple to
+use but with much power and versatility underneath. Features include
+customizable functions, units, arbitrary precision, plotting, and
+a user-friendly interface.
+
+WWW: http://qalculate.sourceforge.net
diff --git a/math/libqalculate/pkg-plist b/math/libqalculate/pkg-plist
new file mode 100644
index 000000000000..304163f74c6b
--- /dev/null
+++ b/math/libqalculate/pkg-plist
@@ -0,0 +1,29 @@
+bin/qalc
+include/libqalculate/Function.h
+include/libqalculate/Calculator.h
+include/libqalculate/DataSet.h
+include/libqalculate/Variable.h
+include/libqalculate/ExpressionItem.h
+include/libqalculate/Number.h
+include/libqalculate/MathStructure.h
+include/libqalculate/Prefix.h
+include/libqalculate/util.h
+include/libqalculate/includes.h
+include/libqalculate/Unit.h
+include/libqalculate/BuiltinFunctions.h
+include/libqalculate/qalculate.h
+lib/libqalculate.a
+lib/libqalculate.la
+lib/libqalculate.so
+lib/libqalculate.so.0
+libdata/pkgconfig/libqalculate.pc
+share/locale/sv/LC_MESSAGES/libqalculate.mo
+share/qalculate/datasets.xml
+share/qalculate/elements.xml
+share/qalculate/functions.xml
+share/qalculate/planets.xml
+share/qalculate/prefixes.xml
+share/qalculate/units.xml
+share/qalculate/variables.xml
+@dirrm include/libqalculate
+@dirrm share/qalculate