aboutsummaryrefslogtreecommitdiffstats
path: root/math/librandlib
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-10-26 15:45:01 +0800
committerasami <asami@FreeBSD.org>1998-10-26 15:45:01 +0800
commit7161a558980263ae33d0b0ab30b9259920fd9376 (patch)
treea87bcd709cff3d1d093591e0966b840598b01cc0 /math/librandlib
parent34a8ba2ad0defb4a7661aaed341f2c692501a62d (diff)
downloadfreebsd-ports-gnome-7161a558980263ae33d0b0ab30b9259920fd9376.tar.gz
freebsd-ports-gnome-7161a558980263ae33d0b0ab30b9259920fd9376.tar.zst
freebsd-ports-gnome-7161a558980263ae33d0b0ab30b9259920fd9376.zip
Make .so link in a.out case.
Diffstat (limited to 'math/librandlib')
-rw-r--r--math/librandlib/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/librandlib/Makefile b/math/librandlib/Makefile
index 3aa2e9e295d9..7f899107d9ed 100644
--- a/math/librandlib/Makefile
+++ b/math/librandlib/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 April 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.1.1.1 1997/04/07 07:02:50 tg Exp $
+# $Id: Makefile,v 1.2 1997/04/23 06:57:54 tg Exp $
#
DISTNAME= ranlib.c
@@ -23,6 +23,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ranlib
@${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/ranlib
.endif
+ if [ "${PORTOBJFORMAT}" = "aout" ]; then \
+ ${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so; \
+ fi
@${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>