aboutsummaryrefslogtreecommitdiffstats
path: root/math/libranlib
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /math/libranlib
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'math/libranlib')
-rw-r--r--math/libranlib/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/libranlib/Makefile b/math/libranlib/Makefile
index 7f899107d9ed..427dbe91cabf 100644
--- a/math/libranlib/Makefile
+++ b/math/libranlib/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 April 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.2 1997/04/23 06:57:54 tg Exp $
+# $Id: Makefile,v 1.3 1998/10/26 07:45:01 asami Exp $
#
DISTNAME= ranlib.c
@@ -15,6 +15,8 @@ MAINTAINER= tg@FreeBSD.ORG
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+.include <bsd.port.pre.mk>
+
post-extract:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
@@ -23,9 +25,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ranlib
@${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/ranlib
.endif
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so
+.endif
@${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>