aboutsummaryrefslogtreecommitdiffstats
path: root/math/libtommath/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-08-29 22:28:15 +0800
committerpav <pav@FreeBSD.org>2005-08-29 22:28:15 +0800
commit96070fc409976997e50ecd69c0b8c424f280fd53 (patch)
tree781a2c4efc6070205705c22efe2a2a37a7667137 /math/libtommath/Makefile
parent492976529f5d456872398820507c6d2905614efc (diff)
downloadfreebsd-ports-gnome-96070fc409976997e50ecd69c0b8c424f280fd53.tar.gz
freebsd-ports-gnome-96070fc409976997e50ecd69c0b8c424f280fd53.tar.zst
freebsd-ports-gnome-96070fc409976997e50ecd69c0b8c424f280fd53.zip
LibTomMath provides highly optimized and portable routines for a vast
majority of integer based number theoretic applications (including public key cryptography). PR: ports/85043 Submitted by: Wesley Shields <wxs@csh.rit.edu>
Diffstat (limited to 'math/libtommath/Makefile')
-rw-r--r--math/libtommath/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
new file mode 100644
index 000000000000..f57fa688cfc1
--- /dev/null
+++ b/math/libtommath/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: libtommath
+# Date created: 05 Aug 2005
+# Whom: Wesley Shields <wxs@csh.rit.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtommath
+PORTVERSION= 0.36
+CATEGORIES= math
+MASTER_SITES= http://math.libtomcrypt.org/files/
+DISTNAME= ltm-${PORTVERSION}
+
+MAINTAINER= wxs@csh.rit.edu
+COMMENT= Comprehensive, modular and portable mathematical routines
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKEFILE= makefile
+USE_BZIP2= yes
+USE_GMAKE= yes
+ALL_TARGET= default
+
+.include <bsd.port.mk>