aboutsummaryrefslogtreecommitdiffstats
path: root/math/mathomatic/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-05-02 18:54:09 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-05-02 18:54:09 +0800
commit291166e6303614be542ffea77f220e833e557e59 (patch)
tree4114ed5807dfa3a2def719248fcfb8bef02b1424 /math/mathomatic/Makefile
parent3a630118d94196bd642a7d3fd4293e4aaeb346d7 (diff)
downloadfreebsd-ports-gnome-291166e6303614be542ffea77f220e833e557e59.tar.gz
freebsd-ports-gnome-291166e6303614be542ffea77f220e833e557e59.tar.zst
freebsd-ports-gnome-291166e6303614be542ffea77f220e833e557e59.zip
Update to 15.0.8
Diffstat (limited to 'math/mathomatic/Makefile')
-rw-r--r--math/mathomatic/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/math/mathomatic/Makefile b/math/mathomatic/Makefile
index 92f3670029dc..b66c7c403f16 100644
--- a/math/mathomatic/Makefile
+++ b/math/mathomatic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mathomatic
-PORTVERSION= 15.0.7
+PORTVERSION= 15.0.8
CATEGORIES= math
MASTER_SITES= http://www.panix.com/~gesslein/ \
CRITICAL
@@ -24,9 +24,23 @@ PORTDOCS= *
MAN1= mathomatic.1
+OPTIONS= PDF "Install PDF manual (requires htmldoc)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PDF)
+BUILD_DEPENDS+= htmldoc:${PORTSDIR}/textproc/htmldoc
+.endif
+
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+.if defined(WITH_PDF)
+post-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} pdf
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/mathomatic.1 ${PREFIX}/man/man1
@@ -46,4 +60,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>