aboutsummaryrefslogtreecommitdiffstats
path: root/math/metis/Makefile
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-04-26 11:55:22 +0800
committermph <mph@FreeBSD.org>1998-04-26 11:55:22 +0800
commit4ef891c95f373fde8f56a3061fa99d9970e115c8 (patch)
tree5290eebb2d35886b706b86ff26b4aeba8e3f55f3 /math/metis/Makefile
parent72452f755b902ac09b147bdda6b6cae91846d7fe (diff)
downloadfreebsd-ports-gnome-4ef891c95f373fde8f56a3061fa99d9970e115c8.tar.gz
freebsd-ports-gnome-4ef891c95f373fde8f56a3061fa99d9970e115c8.tar.zst
freebsd-ports-gnome-4ef891c95f373fde8f56a3061fa99d9970e115c8.zip
Import of METIS, a package for unstructured graph partitioning.
At least, that's what the COMMENT says it does... PR: 4920 Submitted by: Pedro Giffuni <giffunip@asme.org>
Diffstat (limited to 'math/metis/Makefile')
-rw-r--r--math/metis/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/metis/Makefile b/math/metis/Makefile
new file mode 100644
index 000000000000..b8c9952acce0
--- /dev/null
+++ b/math/metis/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: METIS
+# Version required: 3.0
+# Date created: 26 Oct 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $Id$
+#
+
+DISTNAME= metis-3.0
+CATEGORIES= math
+MASTER_SITES= http://www.cs.umn.edu/~karypis/metis/metis/files/
+
+MAINTAINER= giffunip@asme.org
+
+ALL_TARGET=
+
+do-install:
+ $(INSTALL_PROGRAM) $(WRKSRC)/pmetis $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/kmetis $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/oemetis $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/onmetis $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/partnmesh $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/partdmesh $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/mesh2nodal $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/mesh2dual $(PREFIX)/bin
+ $(INSTALL_PROGRAM) $(WRKSRC)/graphchk $(PREFIX)/bin
+ $(INSTALL_DATA) $(WRKSRC)/libmetis.a $(PREFIX)/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} $(PREFIX)/share/doc/METIS
+ $(INSTALL_DATA) ${WRKSRC}/Doc/manual.ps $(PREFIX)/share/doc/METIS
+.endif
+
+.include <bsd.port.mk>