aboutsummaryrefslogtreecommitdiffstats
path: root/math/metis
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-02-23 02:47:27 +0800
committerthierry <thierry@FreeBSD.org>2006-02-23 02:47:27 +0800
commitef9b8c21ef56251d89fd44b01349fd7d12e00d70 (patch)
tree1f0bf458e976bb165dc6605c039e2e3c3f9d2bf4 /math/metis
parenta3df4f2910c64420f829949fecc62347b4c0cc9b (diff)
downloadfreebsd-ports-gnome-ef9b8c21ef56251d89fd44b01349fd7d12e00d70.tar.gz
freebsd-ports-gnome-ef9b8c21ef56251d89fd44b01349fd7d12e00d70.tar.zst
freebsd-ports-gnome-ef9b8c21ef56251d89fd44b01349fd7d12e00d70.zip
Add -fPIC for amd64, this will help CalculiX build on amd64 when the
atlas libraries are not build statically. For now a shared library, and therefore a run dependency to the ports that build with metis, is not convenient. Since I'm there, fix MASTER_SITES. PR: 93714 Submitted by: Pedro F. Giffuni <giffunip (at) asme.org>
Diffstat (limited to 'math/metis')
-rw-r--r--math/metis/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/math/metis/Makefile b/math/metis/Makefile
index c921eb018bf5..84a6d2c1cdcd 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -8,18 +8,27 @@
PORTNAME= metis
PORTVERSION= 4.0
CATEGORIES= math
-MASTER_SITES= http://www-users.cs.umn.edu/~karypis/metis/metis/files/
+MASTER_SITES= http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/ \
+ http://www-users.cs.umn.edu/~karypis/metis/metis/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= A package for unstructured graph partitioning
-CONFLICTS= metis-edf-*
+CONFLICTS= metis-edf-[0-9]*
ALL_TARGET=
PROGRAMS= graphchk kmetis mesh2dual mesh2nodal \
oemetis onmetis partnmesh partdmesh pmetis
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+post-configure:
+ @${REINPLACE_CMD} -e 's+COPTIONS =+COPTIONS = -fPIC+;' \
+ ${WRKSRC}/Makefile.in
+.endif
+
do-install:
.for p in ${PROGRAMS}
${INSTALL_PROGRAM} ${WRKSRC}/${p} ${PREFIX}/bin
@@ -32,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Doc/manual.ps ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>