aboutsummaryrefslogtreecommitdiffstats
path: root/math/mingw32-libgmp
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-09-23 21:16:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-09-23 21:16:00 +0800
commitc225d051e779272883f286867af32040be1e00b7 (patch)
tree85fd70ea85bec340af8a6c891a9f9091563b881b /math/mingw32-libgmp
parent374b7cff3f587f2425f7283d244649a474e9d512 (diff)
downloadfreebsd-ports-gnome-c225d051e779272883f286867af32040be1e00b7.tar.gz
freebsd-ports-gnome-c225d051e779272883f286867af32040be1e00b7.tar.zst
freebsd-ports-gnome-c225d051e779272883f286867af32040be1e00b7.zip
GMP is a free library for arbitrary precision arithmetic, operating
on signed integers, rational numbers, and floating point numbers. There is no limit to the precision except the ones implied by the available memory in the machine GMP runs on. GMP has a rich set of functions, and the functions have a regular interface. This port compiles libgmp using MinGW32. WWW: http://www.swox.com/gmp/ PR: 123391 Submitted by: Timothy Bourke <timbob at bigpond dot com>
Diffstat (limited to 'math/mingw32-libgmp')
-rw-r--r--math/mingw32-libgmp/Makefile43
-rw-r--r--math/mingw32-libgmp/distinfo3
-rw-r--r--math/mingw32-libgmp/pkg-descr9
-rw-r--r--math/mingw32-libgmp/pkg-plist9
4 files changed, 64 insertions, 0 deletions
diff --git a/math/mingw32-libgmp/Makefile b/math/mingw32-libgmp/Makefile
new file mode 100644
index 000000000000..edaff7b30043
--- /dev/null
+++ b/math/mingw32-libgmp/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: mingw32-libgmp4
+# Date created: 28 April 2008
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgmp4
+PORTVERSION= 4.2.2
+CATEGORIES= math devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= gmp
+PKGNAMEPREFIX= mingw32-
+DISTNAME= gmp-${PORTVERSION}
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= Library for arbitrary precision arithmetic (MinGW32)
+
+BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
+ mingwm10.dll:${PORTSDIR}/devel/mingw32-bin-msvcrt
+
+GNU_CONFIGURE= yes
+CC= ${PKGNAMEPREFIX}gcc
+CXX= ${PKGNAMEPREFIX}c++
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" \
+ PREFIX="${PREFIX}/${PKGNAMEPREFIX:S/-$//}"
+CONFIGURE_ARGS= --enable-cxx --host=${PKGNAMEPREFIX:S/-$//} \
+ --includedir=${PREFIX}/${PKGNAMEPREFIX:S/-$//}/include \
+ --exec_prefix=${PREFIX}/${PKGNAMEPREFIX:S/-$//} \
+ --datadir=${PREFIX}/${PKGNAMEPREFIX:S/-$//}/share \
+ --libdir=${PREFIX}/${PKGNAMEPREFIX:S/-$//}/lib
+CONFIGURE_TARGET=
+
+INFO= gmp
+INFO_PATH= ${PKGNAMEPREFIX:S/-$//}/info
+
+post-extract:
+ @${RM} -f ${WRKSRC}/doc/gmp.info*
+
+pre-install:
+ ${MKDIR} ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/info
+
+.include <bsd.port.mk>
diff --git a/math/mingw32-libgmp/distinfo b/math/mingw32-libgmp/distinfo
new file mode 100644
index 000000000000..dcb12714f169
--- /dev/null
+++ b/math/mingw32-libgmp/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmp-4.2.2.tar.gz) = 1def49df60248a08374ecd6cdcaa5d3d
+SHA256 (gmp-4.2.2.tar.gz) = db1663aefaa37e6fe69898729ece2a86568792b9009cc1ae4b6b189e0f0fce6a
+SIZE (gmp-4.2.2.tar.gz) = 2279978
diff --git a/math/mingw32-libgmp/pkg-descr b/math/mingw32-libgmp/pkg-descr
new file mode 100644
index 000000000000..159ccbf3d124
--- /dev/null
+++ b/math/mingw32-libgmp/pkg-descr
@@ -0,0 +1,9 @@
+GMP is a free library for arbitrary precision arithmetic, operating
+on signed integers, rational numbers, and floating point numbers.
+There is no limit to the precision except the ones implied by the
+available memory in the machine GMP runs on. GMP has a rich set of
+functions, and the functions have a regular interface.
+
+This port compiles libgmp using MinGW32.
+
+WWW: http://www.swox.com/gmp/
diff --git a/math/mingw32-libgmp/pkg-plist b/math/mingw32-libgmp/pkg-plist
new file mode 100644
index 000000000000..423bcbdfbdb2
--- /dev/null
+++ b/math/mingw32-libgmp/pkg-plist
@@ -0,0 +1,9 @@
+mingw32/include/gmp.h
+mingw32/include/gmpxx.h
+mingw32/lib/libgmp.a
+mingw32/lib/libgmp.la
+mingw32/lib/libgmpxx.a
+mingw32/lib/libgmpxx.la
+@dirrmtry mingw32/include
+@dirrmtry mingw32/lib
+@dirrmtry mingw32