aboutsummaryrefslogtreecommitdiffstats
path: root/math/miracl
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-01-18 09:43:38 +0800
committerlioux <lioux@FreeBSD.org>2005-01-18 09:43:38 +0800
commitc0e7755c9e3bfd8c8fd667e584e4e47444ef6a0d (patch)
treeb38dd7bd70facbb1b2bd96a97f6da35f5a564337 /math/miracl
parent2b636226fade18f8d58aca179d844c756da8d7a7 (diff)
downloadfreebsd-ports-gnome-c0e7755c9e3bfd8c8fd667e584e4e47444ef6a0d.tar.gz
freebsd-ports-gnome-c0e7755c9e3bfd8c8fd667e584e4e47444ef6a0d.tar.zst
freebsd-ports-gnome-c0e7755c9e3bfd8c8fd667e584e4e47444ef6a0d.zip
New port miracl version 4.85: Multiprecision Integer and Rational
Arithmetic C/C++ Library
Diffstat (limited to 'math/miracl')
-rw-r--r--math/miracl/Makefile43
-rw-r--r--math/miracl/distinfo2
-rw-r--r--math/miracl/pkg-descr20
3 files changed, 65 insertions, 0 deletions
diff --git a/math/miracl/Makefile b/math/miracl/Makefile
new file mode 100644
index 000000000000..d8b60dc1a546
--- /dev/null
+++ b/math/miracl/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: MIRACL
+# Date created: Mon Jan 17 21:38:16 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= miracl
+DISTVERSION= 4.85
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.computing.dcu.ie/pub/crypto/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Multiprecision Integer and Rational Arithmetic C/C++ Library
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= ys
+
+EXTRACT_BEFORE_ARGS= -j -aa -L
+
+PLIST_FILES= \
+ lib/libmiracl.a
+
+post-patch:
+# C{C,XX} safeness
+# CFLAGS safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|gcc|${CC}|' \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|-O2|${CFLAGS}|' \
+ ${WRKSRC}/linux
+
+do-build:
+ @cd ${WRKSRC} && ${SH} ./linux
+
+do-install:
+# lib
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.a \
+ ${PREFIX}/lib/lib${PORTNAME}.a
+
+.include <bsd.port.mk>
diff --git a/math/miracl/distinfo b/math/miracl/distinfo
new file mode 100644
index 000000000000..8e1f18b6c6d3
--- /dev/null
+++ b/math/miracl/distinfo
@@ -0,0 +1,2 @@
+MD5 (miracl.zip) = d27a168c47a1d8f27e905125275e2168
+SIZE (miracl.zip) = 1414645
diff --git a/math/miracl/pkg-descr b/math/miracl/pkg-descr
new file mode 100644
index 000000000000..65f4b135e1da
--- /dev/null
+++ b/math/miracl/pkg-descr
@@ -0,0 +1,20 @@
+[ excerpt from developer's web site ]
+
+MIRACL is a Big Number Library which implements all of the primitives
+necessary to design Big Number Cryptography into your real-world
+application. It is primarily a tool for cryptographic system
+implementors. RSA public key cryptography, Diffie-Hellman Key
+exchange, DSA digital signature, they are all just a few procedure
+calls away. Support is also included for even more esoteric Elliptic
+Curves and Lucas function based schemes. The latest version offers
+full support for Elliptic Curve Cryptography over GF(p) and GF(2m).
+Less well-known techniques can also be implemented as MIRACL allows
+you to work directly and efficiently with the big numbers that are
+the building blocks of number-theoretic cryptography. Although
+implemented as a C library, a well-thought out C++ wrapper is
+provided, which greatly simplifies program development. Most example
+programs (25+ of them) are provided in both C and C++ versions.
+
+WWW: http://indigo.ie/~mscott/
+
+-- lioux@FreeBSD.org