aboutsummaryrefslogtreecommitdiffstats
path: root/math/moo
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2017-05-30 21:51:10 +0800
committerskreuzer <skreuzer@FreeBSD.org>2017-05-30 21:51:10 +0800
commitebd89a431c7f1c16710fec3408143abad1e0a055 (patch)
tree3c0342146ad1f9c3235a952d0f66cf9f6163e435 /math/moo
parent30c9880099e202a5310eabc93b44e2a63ce1ed95 (diff)
downloadfreebsd-ports-gnome-ebd89a431c7f1c16710fec3408143abad1e0a055.tar.gz
freebsd-ports-gnome-ebd89a431c7f1c16710fec3408143abad1e0a055.tar.zst
freebsd-ports-gnome-ebd89a431c7f1c16710fec3408143abad1e0a055.zip
Update to version 1.5
Diffstat (limited to 'math/moo')
-rw-r--r--math/moo/Makefile8
-rw-r--r--math/moo/distinfo5
-rw-r--r--math/moo/files/patch-Makefile18
-rw-r--r--math/moo/files/patch-moo.y26
4 files changed, 31 insertions, 26 deletions
diff --git a/math/moo/Makefile b/math/moo/Makefile
index 522417998e44..3902ad3187b2 100644
--- a/math/moo/Makefile
+++ b/math/moo/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= moo
-PORTVERSION= 1.3
+PORTVERSION= 1.5
CATEGORIES= math
-MASTER_SITES= http://www.cyth.net/moo/
-EXTRACT_SUFX= .tgz
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Calculator that accepts C-like syntax as input
+USE_GITHUB= yes
+GH_ACCOUNT= raylai
+GH_TAGNAME= ${PORTVERSION}
+
PLIST_FILES= bin/moo man/man1/moo.1.gz
MAKE_JOBS_UNSAFE= yes
diff --git a/math/moo/distinfo b/math/moo/distinfo
index 67f77bf07f4d..2619299fbedd 100644
--- a/math/moo/distinfo
+++ b/math/moo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (moo-1.3.tgz) = 32d567dc74ac0123034009d570d3809f35d12a13978fb409153520448b40d45f
-SIZE (moo-1.3.tgz) = 7380
+TIMESTAMP = 1496151728
+SHA256 (raylai-moo-1.5_GH0.tar.gz) = d99fc2d858c0efbfd730737b5af47e0a8d0d5e8f48890b049f86a876821aaeb3
+SIZE (raylai-moo-1.5_GH0.tar.gz) = 8661
diff --git a/math/moo/files/patch-Makefile b/math/moo/files/patch-Makefile
deleted file mode 100644
index c11fb19931f8..000000000000
--- a/math/moo/files/patch-Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.orig Thu Apr 5 14:13:26 2007
-+++ Makefile Thu Apr 5 14:14:06 2007
-@@ -3,14 +3,11 @@
- PROG= moo
- SRCS= moo.c scan.c
- CPPFLAGS+= -I${.CURDIR}
--COPTS+= -Wall -W -Wno-unused -Wshadow -pedantic
-+COPTS+= -Wall -W -Wno-unused -Wshadow
- CLEANFILES+= moo.c y.tab.h scan.c lex.yy.c
-
- LOCALBASE?=/usr/local
- BINDIR=${LOCALBASE}/bin
- MANDIR=${LOCALBASE}/man/cat
--
--regress::
-- cd ${.CURDIR}/regress && ${MAKE} MOO=${.OBJDIR}/moo
-
- .include <bsd.prog.mk>
diff --git a/math/moo/files/patch-moo.y b/math/moo/files/patch-moo.y
index 14776a3a6668..9d9ea2a78efe 100644
--- a/math/moo/files/patch-moo.y
+++ b/math/moo/files/patch-moo.y
@@ -1,6 +1,6 @@
---- moo.y.orig Thu Apr 5 14:14:22 2007
-+++ moo.y Thu Apr 5 14:14:29 2007
-@@ -37,7 +37,7 @@
+--- moo.y.orig 2016-06-04 10:05:27 UTC
++++ moo.y
+@@ -34,7 +34,7 @@ static int used_oct;
static void divbyzero(void);
static void printnum(int64_t);
@@ -9,3 +9,23 @@
void yyerror(char *);
int yylex(void);
int yyparse(void);
+@@ -317,9 +317,6 @@ main(int argc, char *argv[])
+ {
+ int ch;
+
+- if (pledge("stdio tmppath", NULL) == -1)
+- err(1, "pledge");
+-
+ while ((ch = getopt(argc, argv, "0123456789b:lsuw:")) != -1)
+ switch (ch) {
+ /*
+@@ -403,9 +400,6 @@ DONEPARSING:
+ yyin = sfp;
+ }
+
+- if (pledge("stdio", NULL) == -1)
+- err(1, "pledge");
+-
+ yyparse();
+
+ return (0);