aboutsummaryrefslogtreecommitdiffstats
path: root/math/mpc
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-06-11 23:09:45 +0800
committerale <ale@FreeBSD.org>2010-06-11 23:09:45 +0800
commitde6cee0efd7c72a3035c9aa98e07c6ece3b69d05 (patch)
tree1be586debb97ea8adfbbf5f0039131c8ae668ce8 /math/mpc
parent9fe693d141c24960fa238bc22f6a7a9da20b9890 (diff)
downloadfreebsd-ports-gnome-de6cee0efd7c72a3035c9aa98e07c6ece3b69d05.tar.gz
freebsd-ports-gnome-de6cee0efd7c72a3035c9aa98e07c6ece3b69d05.tar.zst
freebsd-ports-gnome-de6cee0efd7c72a3035c9aa98e07c6ece3b69d05.zip
Chase mpfr library and bump PORTREVISION.
Diffstat (limited to 'math/mpc')
-rw-r--r--math/mpc/Makefile4
-rw-r--r--math/mpc/files/patch-src_acos.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/math/mpc/Makefile b/math/mpc/Makefile
index e790b41fd924..6f2eb2fa4813 100644
--- a/math/mpc/Makefile
+++ b/math/mpc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpc
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math devel
MASTER_SITES= http://www.multiprecision.org/mpc/download/
@@ -15,7 +15,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= Library of complex numbers with arbitrarily high precision
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gmp=${LOCALBASE} \
diff --git a/math/mpc/files/patch-src_acos.c b/math/mpc/files/patch-src_acos.c
new file mode 100644
index 000000000000..15ffa52b44e8
--- /dev/null
+++ b/math/mpc/files/patch-src_acos.c
@@ -0,0 +1,11 @@
+--- src/acos.c.orig 2010-06-11 16:14:09.000000000 +0200
++++ src/acos.c 2010-06-11 16:14:30.000000000 +0200
+@@ -189,7 +189,7 @@
+ rnd_im = rnd_im == GMP_RNDU ? GMP_RNDD
+ : rnd_im == GMP_RNDD ? GMP_RNDU
+ #if MPFR_VERSION_MAJOR >= 3
+- : rnd_im == GMP_RNDA ? GMP_RNDZ
++ : rnd_im == MPFR_RNDA ? MPFR_RNDZ
+ #endif
+ : rnd_im;
+ rnd1 = RNDC(GMP_RNDN, rnd_im);