aboutsummaryrefslogtreecommitdiffstats
path: root/math/mpfr
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-08-29 22:00:54 +0800
committerale <ale@FreeBSD.org>2005-08-29 22:00:54 +0800
commit762d0aef958103b1d9672f30be6329fec746a42d (patch)
tree7dedc0a51bad945608ff6f72f5060f7484824529 /math/mpfr
parentb34ec410a7ae5d1de7b05a69db09caad3cd3a5cc (diff)
downloadfreebsd-ports-gnome-762d0aef958103b1d9672f30be6329fec746a42d.tar.gz
freebsd-ports-gnome-762d0aef958103b1d9672f30be6329fec746a42d.tar.zst
freebsd-ports-gnome-762d0aef958103b1d9672f30be6329fec746a42d.zip
Add mpfr 2.1.2, a library for multiple-precision floating-point
computations. PR: ports/84724 Submitted by: Steven G. Kargl <kargl@troutmask.apl.washington.edu>
Diffstat (limited to 'math/mpfr')
-rw-r--r--math/mpfr/Makefile23
-rw-r--r--math/mpfr/distinfo2
-rw-r--r--math/mpfr/pkg-descr13
-rw-r--r--math/mpfr/pkg-plist3
4 files changed, 41 insertions, 0 deletions
diff --git a/math/mpfr/Makefile b/math/mpfr/Makefile
new file mode 100644
index 000000000000..6bdd68d30486
--- /dev/null
+++ b/math/mpfr/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mpfr
+# Date created: 28 Aug 2005
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpfr
+PORTVERSION= 2.1.2
+CATEGORIES= math devel
+MASTER_SITES= http://www.mpfr.org/mpfr-current/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A library for multiple-precision floating-point computations
+
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
+
+INFO= mpfr
+
+.include <bsd.port.mk>
diff --git a/math/mpfr/distinfo b/math/mpfr/distinfo
new file mode 100644
index 000000000000..26e8045aa91c
--- /dev/null
+++ b/math/mpfr/distinfo
@@ -0,0 +1,2 @@
+MD5 (mpfr-2.1.2.tar.gz) = d3bf773894478bf71af87f681b6819a1
+SIZE (mpfr-2.1.2.tar.gz) = 622693
diff --git a/math/mpfr/pkg-descr b/math/mpfr/pkg-descr
new file mode 100644
index 000000000000..22b3e44c49fb
--- /dev/null
+++ b/math/mpfr/pkg-descr
@@ -0,0 +1,13 @@
+The MPFR library is a C library for multiple-precision floating-point
+computations with exact rounding (also called correct rounding). It
+is based on the GMP multiple-precision library.
+
+The main goal of MPFR is to provide a library for multiple-precision
+floating-point computation which is both efficient and has a well-defined
+semantics. It copies the good ideas from the ANSI/IEEE-754 standard for
+double-precision floating-point arithmetic (53-bit mantissa).
+
+WWW: http://www.mpfr/org/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/math/mpfr/pkg-plist b/math/mpfr/pkg-plist
new file mode 100644
index 000000000000..8ce14d435be4
--- /dev/null
+++ b/math/mpfr/pkg-plist
@@ -0,0 +1,3 @@
+lib/libmpfr.a
+include/mpfr.h
+include/mpf2mpfr.h