aboutsummaryrefslogtreecommitdiffstats
path: root/math/msieve/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-06-24 17:21:54 +0800
committerbf <bf@FreeBSD.org>2011-06-24 17:21:54 +0800
commitac169fee9b42ed97fb608f930f7d7bc7b8a2a58e (patch)
treee019b29d6e56b8e6932c4e27983a3a3d48ac6d5c /math/msieve/Makefile
parentad5cfee1c5dae45fbfbf2f69bff9f2567392645b (diff)
downloadfreebsd-ports-gnome-ac169fee9b42ed97fb608f930f7d7bc7b8a2a58e.tar.gz
freebsd-ports-gnome-ac169fee9b42ed97fb608f930f7d7bc7b8a2a58e.tar.zst
freebsd-ports-gnome-ac169fee9b42ed97fb608f930f7d7bc7b8a2a58e.zip
update to 1.49
Diffstat (limited to 'math/msieve/Makefile')
-rw-r--r--math/msieve/Makefile36
1 files changed, 19 insertions, 17 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index 8f6afb77b1a7..6aee0ef06a6c 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= msieve
-PORTVERSION= 1.48
+PORTVERSION= 1.49
CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= \
@@ -20,12 +20,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libecm.a:${PORTSDIR}/math/gmp-ecm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= LDFLAGS="${LDFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" ECM=1
-PLIST_FILES= bin/msieve lib/libmsieve.a include/msieve/msieve.h \
- include/msieve/mp.h include/msieve/util.h
+HEADERS= mp.h msieve.h util.h
+PLIST_FILES= bin/msieve lib/libmsieve.a ${HEADERS:S|^|include/msieve/|}
PLIST_DIRS= include/msieve
PORTDOCS= Changes Readme Readme.nfs Readme.qs
@@ -38,30 +38,32 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -DNDEBUG
.endif
.if ${OSVERSION} >= 700042 && ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64-7
+BROKEN= Does not compile on sparc64
.endif
-ALL_TARGET= generic
.if ${ARCH} == "i386"
ALL_TARGET= x86
-.endif
-.if ${ARCH} == "amd64"
+.elif ${ARCH} == "amd64"
ALL_TARGET= x86_64
+.else
+ALL_TARGET= generic
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "\|^CC =|d" -e "\|^OPT_FLAGS =|d" \
+ -e "\|^CFLAGS =|s|=|+=|" ${WRKSRC}/Makefile
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/msieve ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/include/msieve
- ${INSTALL_DATA} ${WRKSRC}/include/msieve.h ${PREFIX}/include/msieve
- ${INSTALL_DATA} ${WRKSRC}/include/mp.h ${PREFIX}/include/msieve
- ${INSTALL_DATA} ${WRKSRC}/include/util.h ${PREFIX}/include/msieve
- ${INSTALL_DATA} ${WRKSRC}/libmsieve.a ${PREFIX}/lib
+ @${INSTALL_PROGRAM} ${WRKSRC}/msieve ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/include/msieve
+ @(cd ${WRKSRC}/include; ${INSTALL_DATA} ${HEADERS} ${PREFIX}/include/msieve)
+ @${INSTALL_DATA} ${WRKSRC}/libmsieve.a ${PREFIX}/lib
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
regression-test test check: build
- @( cd ${WRKSRC} ; ./msieve -q -d 1 2385734365243128176756453434347656453122245767798 )
+ @(cd ${WRKSRC}; ./msieve -q -d 1 2385734365243128176756453434347656453122245767798)
.include <bsd.port.post.mk>