aboutsummaryrefslogtreecommitdiffstats
path: root/math/ndiff
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-02-19 06:02:39 +0800
committerglewis <glewis@FreeBSD.org>2004-02-19 06:02:39 +0800
commitf0177c2a34da63652c9a6890b511605222bbcc4a (patch)
tree021ce59faba3fad84ef14712575ff10467b0b8d8 /math/ndiff
parent579ca4a0ba661c06a837728c763fe4df8643101f (diff)
downloadfreebsd-ports-gnome-f0177c2a34da63652c9a6890b511605222bbcc4a.tar.gz
freebsd-ports-gnome-f0177c2a34da63652c9a6890b511605222bbcc4a.tar.zst
freebsd-ports-gnome-f0177c2a34da63652c9a6890b511605222bbcc4a.zip
Add a port of ndiff:
ndiff is a utility for comparing putatively similar files, ignoring small numeric differences. The utility is written by Nelson H. F. Beebe and covered by the GNU General Public License (GPL), version 2. It may be built with arbitrary precision support (more powerful) or using built-in floating point precision, see Makefile. Assessing the consistency of a numerical program run in multiple environments (operating systems, architectures, or compilers) can be a difficult task for a human, as small differences in numerical output values are expected. File differencing utilites, such as diff(1), will generally produce voluminous output, often longer than the original files. ndiff solves this problem. Taking two two text files expected to be identical, or at least numerically similar, it allows to specify absolute and/or relative error tolerances for differences between numerical values in the two files, and then reports only the lines with values exceeding those tolerances. It also tells by how much they differ. A simple example: % ndiff --relative-error 1.0e-3 test019.txt.1 test019.txt.2 ### Maximum relative error in matching lines = 8.64e-51 at line 129 field 4 WWW: http://www.math.utah.edu/~beebe/software/ndiff/ I've cleaned up the submitted version a little. PR: 62221 Submitted by: Stefan A. Deutscher <sad@mailaps.org>
Diffstat (limited to 'math/ndiff')
-rw-r--r--math/ndiff/Makefile44
-rw-r--r--math/ndiff/distinfo2
-rw-r--r--math/ndiff/files/patch-Makefile.in36
-rw-r--r--math/ndiff/pkg-descr24
-rw-r--r--math/ndiff/pkg-plist4
5 files changed, 110 insertions, 0 deletions
diff --git a/math/ndiff/Makefile b/math/ndiff/Makefile
new file mode 100644
index 000000000000..e32da3cb94aa
--- /dev/null
+++ b/math/ndiff/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ndiff
+# Date created: 31 January 2004
+# Whom: Stefan A. Deutscher (sad@mailaps.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ndiff
+PORTVERSION= 2.00
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.math.utah.edu/pub/misc/
+PKGNAMEPREFIX=
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Compare putatively similar files, ignoring small numeric differences
+
+.if !defined(WITHOUT_GMP)
+LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp-freebsd
+.endif
+
+GNU_CONFIGURE= yes
+ALL_TARGET= all check
+
+MAN1= ndiff.1
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-build:
+ @${ECHO_MSG} "If there were no errors in the above checks then type"
+ @${ECHO_MSG}
+ @${ECHO_MSG} " ${MAKE} install"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "to install ${PORTNAME}-${PORTVERSION}"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.pdf ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.ps ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ndiff/distinfo b/math/ndiff/distinfo
new file mode 100644
index 000000000000..935656e1040b
--- /dev/null
+++ b/math/ndiff/distinfo
@@ -0,0 +1,2 @@
+MD5 (ndiff-2.00.tar.gz) = 885548b4dc26e72c5455bebb5ba6c16d
+SIZE (ndiff-2.00.tar.gz) = 230850
diff --git a/math/ndiff/files/patch-Makefile.in b/math/ndiff/files/patch-Makefile.in
new file mode 100644
index 000000000000..a9e603a03884
--- /dev/null
+++ b/math/ndiff/files/patch-Makefile.in
@@ -0,0 +1,36 @@
+--- Makefile.in.orig Wed Feb 18 14:17:22 2004
++++ Makefile.in Wed Feb 18 14:19:31 2004
+@@ -602,14 +602,12 @@
+ if test -f $(PROGNAME) ; \
+ then \
+ $(CP) $(PROGNAME) $(bindir)/$(PROGNAME) ; \
+- $(LN) $(bindir)/$(PROGNAME) $(bindir)/$(PROGNAME)-$(VERSION) ; \
+ else \
+ for f in $(SHFILES) ; \
+ do \
+ g=`basename $$f .sh` ; \
+ $(SEDCMD) $$f | $(CHECKSUM) > $(bindir)/$$g ; \
+- $(LN) $(bindir)/$$g $(bindir)/$$g-$(VERSION) ; \
+- $(CHMOD) 775 $(bindir)/$$g $(bindir)/$$g-$(VERSION) ; \
++ $(CHMOD) 775 $(bindir)/$$g ; \
+ done ; \
+ fi
+
+@@ -635,7 +633,7 @@
+ install-show:
+ @echo ''
+ @echo Installed files...
+- @$(LS) -l $(bindir)/$(PROGNAME) $(bindir)/$(PROGNAME)-$(VERSION)
++ @$(LS) -l $(bindir)/$(PROGNAME)
+ @$(LS) -l $(mandir)/$(PROGNAME).$(manext)
+ @if test -d $(shrlibdir) ; then $(LS) -lR $(shrlibdir)/* ; fi
+ @echo ''
+@@ -703,7 +701,7 @@
+ uninstall-exe:
+ -for f in $(PROGRAMS) ; \
+ do \
+- $(RM) $(bindir)/$$f $(bindir)/$$f-$(VERSION) 2>/dev/null; \
++ $(RM) $(bindir)/$$f 2>/dev/null; \
+ done
+
+ uninstall-man:
diff --git a/math/ndiff/pkg-descr b/math/ndiff/pkg-descr
new file mode 100644
index 000000000000..e505b7222d95
--- /dev/null
+++ b/math/ndiff/pkg-descr
@@ -0,0 +1,24 @@
+ndiff is a utility for comparing putatively similar files, ignoring small
+numeric differences. The utility is written by Nelson H. F. Beebe and
+covered by the GNU General Public License (GPL), version 2. It may be
+built with arbitrary precision support (more powerful) or using built-in
+floating point precision, see Makefile.
+
+Assessing the consistency of a numerical program run in multiple
+environments (operating systems, architectures, or compilers) can be a
+difficult task for a human, as small differences in numerical output values
+are expected. File differencing utilites, such as diff(1), will generally
+produce voluminous output, often longer than the original files.
+
+ndiff solves this problem. Taking two two text files expected to be
+identical, or at least numerically similar, it allows to specify absolute
+and/or relative error tolerances for differences between numerical values
+in the two files, and then reports only the lines with values exceeding
+those tolerances. It also tells by how much they differ. A simple example:
+
+% ndiff --relative-error 1.0e-3 test019.txt.1 test019.txt.2
+### Maximum relative error in matching lines = 8.64e-51 at line 129 field 4
+
+WWW: http://www.math.utah.edu/~beebe/software/ndiff/
+
+Have fun. Stefan (sad@mailaps.org)
diff --git a/math/ndiff/pkg-plist b/math/ndiff/pkg-plist
new file mode 100644
index 000000000000..b895fb0b1f7a
--- /dev/null
+++ b/math/ndiff/pkg-plist
@@ -0,0 +1,4 @@
+bin/ndiff
+share/lib/ndiff/ndiff-2.00/ndiff.awk
+@dirrm share/lib/ndiff/ndiff-2.00
+@dirrm share/lib/ndiff