aboutsummaryrefslogtreecommitdiffstats
path: root/math/ocaml-ocamlgraph/Makefile
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-03-04 12:16:16 +0800
committermmokhi <mmokhi@FreeBSD.org>2017-03-04 12:16:16 +0800
commit7bb2b6ccaa6a92aed9866207ed469f16382c5ce5 (patch)
treeddafa0cd5505d8e54f7c14744b3cce19e901a7a6 /math/ocaml-ocamlgraph/Makefile
parentcbb166ff4fbbd48e4537245dbb4ec2c44b573a20 (diff)
downloadfreebsd-ports-gnome-7bb2b6ccaa6a92aed9866207ed469f16382c5ce5.tar.gz
freebsd-ports-gnome-7bb2b6ccaa6a92aed9866207ed469f16382c5ce5.tar.zst
freebsd-ports-gnome-7bb2b6ccaa6a92aed9866207ed469f16382c5ce5.zip
math/ocaml-ocamlgraph: Fix finding via ocaml's ld.conf
Reviewed by: feld, mat Approved by: feld, mat (mentors) Differential Revision: https://reviews.freebsd.org/D9790
Diffstat (limited to 'math/ocaml-ocamlgraph/Makefile')
-rw-r--r--math/ocaml-ocamlgraph/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/ocaml-ocamlgraph/Makefile b/math/ocaml-ocamlgraph/Makefile
index 77818ddbd237..3dd1049a0baa 100644
--- a/math/ocaml-ocamlgraph/Makefile
+++ b/math/ocaml-ocamlgraph/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ocamlgraph
PORTVERSION= 1.8.7
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://ocamlgraph.lri.fr/download/ \
ftp://ftp.stack.nl/pub/users/johans/ocamlgraph/
@@ -24,9 +25,10 @@ USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAMLFIND_PLIST= yes
+OCAML_LDLIBS= ${OCAML_LIBDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-PLIST_SUB+= OCAMLGRAPHDIR="${OCAML_LIBDIR}/${PORTNAME}"
+PLIST_SUB+= OCAMLGRAPHDIR="${OCAML_LDLIBS}"
ALL_TARGET= all
INSTALL_TARGET= install
@@ -51,6 +53,7 @@ post-patch:
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/META ${STAGEDIR}${PREFIX}/${OCAML_LDLIBS}
.endif
.include <bsd.port.mk>