aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave-forge-image
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-11-21 09:17:40 +0800
committerstephen <stephen@FreeBSD.org>2011-11-21 09:17:40 +0800
commit15f510895764d0ca91b3b5e0ff00062062228a82 (patch)
treef1ebccd821200bc4dad8b72848f19ed95689f5ed /math/octave-forge-image
parent970f2630fdf56f4ed13e74663b362444d6795590 (diff)
downloadfreebsd-ports-gnome-15f510895764d0ca91b3b5e0ff00062062228a82.tar.gz
freebsd-ports-gnome-15f510895764d0ca91b3b5e0ff00062062228a82.tar.zst
freebsd-ports-gnome-15f510895764d0ca91b3b5e0ff00062062228a82.zip
- Cosmetic change to Makefile. Use the variable OCTSRC to describe where the
contents of the package are stored. This should make it easier if other people take over maintainership of the octave-forge-* ports. Feature safe: yes
Diffstat (limited to 'math/octave-forge-image')
-rw-r--r--math/octave-forge-image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-image/Makefile b/math/octave-forge-image/Makefile
index 83007638f1ff..c07cfc4b257c 100644
--- a/math/octave-forge-image/Makefile
+++ b/math/octave-forge-image/Makefile
@@ -12,7 +12,11 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
@@ -21,6 +25,6 @@ post-patch:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${DISTNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>