aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave-forge-optim
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-11-21 09:17:40 +0800
committerstephen <stephen@FreeBSD.org>2011-11-21 09:17:40 +0800
commit15f510895764d0ca91b3b5e0ff00062062228a82 (patch)
treef1ebccd821200bc4dad8b72848f19ed95689f5ed /math/octave-forge-optim
parent970f2630fdf56f4ed13e74663b362444d6795590 (diff)
downloadfreebsd-ports-gnome-15f510895764d0ca91b3b5e0ff00062062228a82.tar.gz
freebsd-ports-gnome-15f510895764d0ca91b3b5e0ff00062062228a82.tar.zst
freebsd-ports-gnome-15f510895764d0ca91b3b5e0ff00062062228a82.zip
- Cosmetic change to Makefile. Use the variable OCTSRC to describe where the
contents of the package are stored. This should make it easier if other people take over maintainership of the octave-forge-* ports. Feature safe: yes
Diffstat (limited to 'math/octave-forge-optim')
-rw-r--r--math/octave-forge-optim/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-optim/Makefile b/math/octave-forge-optim/Makefile
index c2e7edbecd70..d0c71d8a867d 100644
--- a/math/octave-forge-optim/Makefile
+++ b/math/octave-forge-optim/Makefile
@@ -12,7 +12,11 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
RUN_DEPENDS+= ${TARBALLS_DIR}/miscellaneous.tar.gz:${PORTSDIR}/math/octave-forge-miscellaneous
RUN_DEPENDS+= ${TARBALLS_DIR}/struct.tar.gz:${PORTSDIR}/math/octave-forge-struct
@@ -21,6 +25,6 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/struct.tar.gz:${PORTSDIR}/math/octave-forge-struct
.include "${PORTSDIR}/Mk/bsd.octave.mk"
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${DISTNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>