aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-07-24 07:41:24 +0800
committermaho <maho@FreeBSD.org>2003-07-24 07:41:24 +0800
commit3543206609d915a043aa0c4020aee0e15f007c7e (patch)
treeb1cda1d848249c8430eb1305ac2b1edc09289295 /math/octave/Makefile
parent049e1b35e79096e1e46ce9c62ccdd3b865217dd4 (diff)
downloadfreebsd-ports-gnome-3543206609d915a043aa0c4020aee0e15f007c7e.tar.gz
freebsd-ports-gnome-3543206609d915a043aa0c4020aee0e15f007c7e.tar.zst
freebsd-ports-gnome-3543206609d915a043aa0c4020aee0e15f007c7e.zip
Add simple wrapper to avoid the error
/usr/libexec/ld-elf.so.1: Shared object "liboctinterp.so" not found PR: 54567,54653 Submitted by: Jonathan <j.e.drews@worldnet.att.net>
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index dd03b8bf3999..ec35ed086b07 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -36,8 +36,7 @@ PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
BLAS_LIBS= "-L${LOCALBASE}/lib -lf77blas -latlas"
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
CONFIGURE_ARGS= --host=${GNU_HOST} \
--with-fftw --with-blas=${BLAS_LIBS} --with-lpack \
@@ -59,9 +58,14 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
post-extract:
@${RM} -f ${WRKSRC}/doc/interpreter/octave.info*
@${RM} -f ${WRKSRC}/doc/liboctave/liboctave.info*
-
post-install:
- $(INSTALL_DATA) $(WRKSRC)/doc/liboctave/liboctave.info $(PREFIX)/info
+ ${RM} ${PREFIX}/bin/octave
+ @${CP} ${FILESDIR}/octave ${WRKDIR}
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g ; \
+ s,%%OCTAVE_VERSION%%,${OCTAVE_VERSION},g' \
+ ${WRKDIR}/octave
+ ${INSTALL_SCRIPT} ${WRKDIR}/octave ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/doc/liboctave/liboctave.info ${PREFIX}/info
install-info --entry='* Octave: (octave). Interactive language for numerical computations.' $(PREFIX)/info/octave.info $(PREFIX)/info/dir
install-info --entry='* LibOctave: (liboctave). C++ class library for Octave.' $(PREFIX)/info/liboctave.info $(PREFIX)/info/dir
.ifndef NOPORTDOCS