aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-05-02 15:18:21 +0800
committerasami <asami@FreeBSD.org>1995-05-02 15:18:21 +0800
commit65ce6af86222631ecf439bf73dae692e63045c8d (patch)
treeac20aff4f6a0fb0c374b0b85db69a9442e4668f9 /math/octave/Makefile
parented657ad5e8cb58b9e949d1a30e969584891f2230 (diff)
downloadfreebsd-ports-gnome-65ce6af86222631ecf439bf73dae692e63045c8d.tar.gz
freebsd-ports-gnome-65ce6af86222631ecf439bf73dae692e63045c8d.tar.zst
freebsd-ports-gnome-65ce6af86222631ecf439bf73dae692e63045c8d.zip
octave-1.1.1, similar to matlab.
Submitted by: Thomas Gellekum <thomas@ghpc8.ihf.rwth-aachen.de>
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
new file mode 100644
index 000000000000..c1c412bd04a8
--- /dev/null
+++ b/math/octave/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: octave
+# Version required: 1.1.1
+# Date created: 26 Apr 1995
+# Whom: thomas@ghpc8.ihf.rwth-aachen.de
+#
+# $Id$
+#
+
+DISTNAME= octave-1.1.1
+CATEGORIES+= math
+KEYWORDS+= math "numeric computation" matlab
+MASTER_SITES= ftp://ftp.che.utexas.edu/pub/octave/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+EXEC_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+PATCH_STRIP= -p1
+MAKE_FLAGS= CFLAGS="-O2 -pipe -m486" CXXFLAGS="-O2 -pipe -m486" LDFLAGS="-s" -f
+
+.include <bsd.port.mk>