aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-11-22 19:14:10 +0800
committerbf <bf@FreeBSD.org>2011-11-22 19:14:10 +0800
commite76c3137d0dc704cf66c758a906a5be85b715a3b (patch)
tree5df944d34b65ba2c3cbfa92e36a81489e70a8220 /math/octave
parent79f1897cd8102cd7c050b91f5ec19e049be5fb80 (diff)
downloadfreebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.tar.gz
freebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.tar.zst
freebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.zip
adjust linking and comments in dependent ports after the math/atlas update;
math/atlas-devel will be updated to use the same constructs at a later date PR: 162706 Approved by: miwi (portmgr) Feature safe: yes
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 6e8114f453c1..9effb425c589 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -47,27 +47,27 @@ MAN1= octave.1 mkoctfile.1 octave-config.1
.include <bsd.port.pre.mk>
-USE_BLAS?= reference
-
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
LAPACK= -lgoto2p
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
-LAPACK= -lalapack_r
+BLAS= -lptf77blas
+LAPACK= -lalapack -lptcblas
.endif
USE_FORTRAN= yes