aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-12-05 10:58:07 +0800
committerobrien <obrien@FreeBSD.org>2004-12-05 10:58:07 +0800
commitd99a211367f70ea9288c6b461a1033f706b2474a (patch)
tree6ef5f7dc7a18010e117954bb8181c994e3812246 /math/octave
parent9563e5cab7583f9e4f2a13577d83278a67ad2154 (diff)
downloadfreebsd-ports-gnome-d99a211367f70ea9288c6b461a1033f706b2474a.tar.gz
freebsd-ports-gnome-d99a211367f70ea9288c6b461a1033f706b2474a.tar.zst
freebsd-ports-gnome-d99a211367f70ea9288c6b461a1033f706b2474a.zip
Unbreak on AMD64 by linking libglob statically vs. dynamically until the
PIC issues are properly dealt with. Submitted by: Roland Smith <rsmith@xs4all.nl>
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 835beaa4d40c..f0e8c59870d1 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -24,10 +24,6 @@ USE_PERL5_BUILD=yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not build on amd64 (Shared libraries must be compiled with -fPIC)"
-.endif
-
.if ${PORTOBJFORMAT} == "elf"
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
.else
@@ -40,9 +36,14 @@ BLAS_LIBS= "-L${LOCALBASE}/lib -lf77blas -lcblas -latlas"
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --host=${GNU_HOST} \
- --with-fftw --with-blas=${BLAS_LIBS} --with-lapack=-lalapack \
- --enable-shared
+CONIGURE_ARGS= --host=${GNU_HOST} \
+ --with-fftw --with-blas=${BLAS_LIBS} --with-lapack=-lalapack
+.if ${ARCH} == "amd64"
+CONFIGURE_ARGS+= --disable-shared
+.else
+CONFIGURE_ARGS+= --enable-shared
+.endif
+
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \