aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-08-01 20:15:44 +0800
committermakc <makc@FreeBSD.org>2010-08-01 20:15:44 +0800
commit6fc66a9994376df1129b9ff3f882b862f2d939bc (patch)
tree2072da32b661cea1bee81c89cb8b26e92022aabf /math/octave
parentef69565af8db85393d61810c1524d6bc30ba9e0b (diff)
downloadfreebsd-ports-gnome-6fc66a9994376df1129b9ff3f882b862f2d939bc.tar.gz
freebsd-ports-gnome-6fc66a9994376df1129b9ff3f882b862f2d939bc.tar.zst
freebsd-ports-gnome-6fc66a9994376df1129b9ff3f882b862f2d939bc.zip
Add option to allow build with either hdf v1.6 or 1.8.
Build with 1.6 by default, since most of the ports still depend on legacy hdf5. PR: ports/148496 Submitted by: makc@ Approved by: maintainer timeout (three weeks)
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index ba1c16c056e7..9d377842618e 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -23,7 +23,6 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
glpk.28:${PORTSDIR}/math/glpk \
- hdf5:${PORTSDIR}/science/hdf5 \
umfpack.1:${PORTSDIR}/math/suitesparse \
qhull:${PORTSDIR}/math/qhull \
arpack:${PORTSDIR}/math/arpack \
@@ -43,8 +42,16 @@ USE_AUTOTOOLS= autoconf:262
INFO= octave liboctave
MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
+OPTIONS= LEGACY_HDF5 "Build with HDF5 v1.6 (otherwise with HDF5 v1.8)" on
+
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_LEGACY_HDF5)
+LIB_DEPENDS+= hdf5:${PORTSDIR}/science/hdf5-18
+.else
+LIB_DEPENDS+= hdf5:${PORTSDIR}/science/hdf5
+.endif
+
USE_BLAS?= reference
.if exists(${LOCALBASE}/lib/libgoto2.so)