aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2010-02-16 14:54:31 +0800
committermaho <maho@FreeBSD.org>2010-02-16 14:54:31 +0800
commitf6ef72c51d59a1fd67bc17885d49099245a9f03d (patch)
tree4f84a60f2a1c2a788ac87038daaf8df4d52215d9 /math/octave
parent09b1264b8e74ab319e260965b5c4973ba876198f (diff)
downloadfreebsd-ports-gnome-f6ef72c51d59a1fd67bc17885d49099245a9f03d.tar.gz
freebsd-ports-gnome-f6ef72c51d59a1fd67bc17885d49099245a9f03d.tar.zst
freebsd-ports-gnome-f6ef72c51d59a1fd67bc17885d49099245a9f03d.zip
Build fix gotoblas.
Feature safe: yes
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 9ca2a8e92aba..1b1eb154a299 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -47,7 +47,7 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -59,10 +59,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+LAPACK= -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r