aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-05-02 15:18:21 +0800
committerasami <asami@FreeBSD.org>1995-05-02 15:18:21 +0800
commit65ce6af86222631ecf439bf73dae692e63045c8d (patch)
treeac20aff4f6a0fb0c374b0b85db69a9442e4668f9 /math/octave
parented657ad5e8cb58b9e949d1a30e969584891f2230 (diff)
downloadfreebsd-ports-gnome-65ce6af86222631ecf439bf73dae692e63045c8d.tar.gz
freebsd-ports-gnome-65ce6af86222631ecf439bf73dae692e63045c8d.tar.zst
freebsd-ports-gnome-65ce6af86222631ecf439bf73dae692e63045c8d.zip
octave-1.1.1, similar to matlab.
Submitted by: Thomas Gellekum <thomas@ghpc8.ihf.rwth-aachen.de>
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile24
-rw-r--r--math/octave/distinfo1
-rw-r--r--math/octave/pkg-comment1
-rw-r--r--math/octave/pkg-descr5
-rw-r--r--math/octave/pkg-plist19
5 files changed, 50 insertions, 0 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
new file mode 100644
index 000000000000..c1c412bd04a8
--- /dev/null
+++ b/math/octave/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: octave
+# Version required: 1.1.1
+# Date created: 26 Apr 1995
+# Whom: thomas@ghpc8.ihf.rwth-aachen.de
+#
+# $Id$
+#
+
+DISTNAME= octave-1.1.1
+CATEGORIES+= math
+KEYWORDS+= math "numeric computation" matlab
+MASTER_SITES= ftp://ftp.che.utexas.edu/pub/octave/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+EXEC_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+PATCH_STRIP= -p1
+MAKE_FLAGS= CFLAGS="-O2 -pipe -m486" CXXFLAGS="-O2 -pipe -m486" LDFLAGS="-s" -f
+
+.include <bsd.port.mk>
diff --git a/math/octave/distinfo b/math/octave/distinfo
new file mode 100644
index 000000000000..febe4891ac60
--- /dev/null
+++ b/math/octave/distinfo
@@ -0,0 +1 @@
+MD5 (octave-1.1.1.tar.gz) = bc319c5e2bdc78790c3adeed6cec39c4
diff --git a/math/octave/pkg-comment b/math/octave/pkg-comment
new file mode 100644
index 000000000000..63602631a389
--- /dev/null
+++ b/math/octave/pkg-comment
@@ -0,0 +1 @@
+octave - High-level interactive language for numerical computations
diff --git a/math/octave/pkg-descr b/math/octave/pkg-descr
new file mode 100644
index 000000000000..c03244971e2a
--- /dev/null
+++ b/math/octave/pkg-descr
@@ -0,0 +1,5 @@
+Octave is a high-level language, primarily intended for numerical
+computations. It provides a convenient command line interface for
+solving linear and nonlinear problems numerically, and for performing
+other numerical experiments. It may also be used as a batch-oriented
+language.
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
new file mode 100644
index 000000000000..0107ba196698
--- /dev/null
+++ b/math/octave/pkg-plist
@@ -0,0 +1,19 @@
+@cwd /usr/local
+lib/octave
+bin/octave
+bin/octave-bug
+bin/octave-1.1.1
+man/man1/octave.1
+info/octave.info
+info/octave.info-1
+info/octave.info-10
+info/octave.info-11
+info/octave.info-2
+info/octave.info-3
+info/octave.info-4
+info/octave.info-5
+info/octave.info-6
+info/octave.info-7
+info/octave.info-8
+info/octave.info-9
+include/octave