aboutsummaryrefslogtreecommitdiffstats
path: root/math/oleo/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-03-20 21:03:54 +0800
committerkevlo <kevlo@FreeBSD.org>2001-03-20 21:03:54 +0800
commitb30ac1f4c6b2b9aad4b0d1603c1306e9ff300f74 (patch)
tree8c87a25aebed3e3e00f131c416d402e65ede5229 /math/oleo/Makefile
parent4d3fa3369e2f87b82df00b38959c7680e0d8ebfd (diff)
downloadfreebsd-ports-gnome-b30ac1f4c6b2b9aad4b0d1603c1306e9ff300f74.tar.gz
freebsd-ports-gnome-b30ac1f4c6b2b9aad4b0d1603c1306e9ff300f74.tar.zst
freebsd-ports-gnome-b30ac1f4c6b2b9aad4b0d1603c1306e9ff300f74.zip
Update to version 1.99.16
PR: 25931 Submitted by: Ports Fury
Diffstat (limited to 'math/oleo/Makefile')
-rw-r--r--math/oleo/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 19babab4287c..beb0f8e00b4b 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= oleo
-PORTVERSION= 1.99.14
+PORTVERSION= 1.99.16
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,23 +14,30 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-.if defined(WITH_MOTIF)
-LIB_DEPENDS+= plot.3:${PORTSDIR}/graphics/plotutils \
- Xbae.8:${PORTSDIR}/x11-toolkits/xbae
-.endif
-USE_XLIB= yes
+USE_BISON= yes
USE_AUTOCONF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --with-x --without-xlt \
- --without-xmhtml --without-SciPlot
+CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
.if defined(WITH_MOTIF)
+LIB_DEPENDS+= plot.3:${PORTSDIR}/graphics/plotutils \
+ Xbae.8:${PORTSDIR}/x11-toolkits/xbae \
+ XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml
USE_MOTIF= yes
CONFIGURE_ARGS+= --with-motif
.else
+USE_XLIB= yes
CONFIGURE_ARGS+= --without-motif
.endif
+pre-everything:
+.if !defined(WITH_MOTIF)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with Motif support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG}
+.endif
+
.include <bsd.port.mk>