aboutsummaryrefslogtreecommitdiffstats
path: root/math/openblas
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-12-16 23:11:34 +0800
committerpawel <pawel@FreeBSD.org>2012-12-16 23:11:34 +0800
commit36db8c794c7f7765ab1baf34e437e416bb635a75 (patch)
tree0c3e9e45c1fff30d4cb6a6441bc3a348ca7be598 /math/openblas
parent22d77e4e42d47dce59458675433346a44fbbf604 (diff)
downloadfreebsd-ports-gnome-36db8c794c7f7765ab1baf34e437e416bb635a75.tar.gz
freebsd-ports-gnome-36db8c794c7f7765ab1baf34e437e416bb635a75.tar.zst
freebsd-ports-gnome-36db8c794c7f7765ab1baf34e437e416bb635a75.zip
- Option descriptions should not be quoted
- Use negation instead of empty() Reported by: jhale
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 075af3cc9a4d..6c0f9e286a40 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -43,10 +43,10 @@ WRKSRC= ${WRKDIR}/${GH_USER}-${GH_PORTNAME}-93dd133
OPTIONS_DEFINE= DYNAMIC_ARCH INTERFACE64 OPENMP AVX
-DYNAMIC_ARCH_DESC= "Support multiple CPU types on i386 and amd64"
-INTERFACE64_DESC= "Use 8 byte integers on 64-bit architectures"
-OPENMP_DESC= "Use OpenMP for threading"
-AVX_DESC= "Support Advanced Vector Extensions (AVX)"
+DYNAMIC_ARCH_DESC= Support multiple CPU types on i386 and amd64
+INTERFACE64_DESC= Use 8 byte integers on 64-bit architectures
+OPENMP_DESC= Use OpenMP for threading
+AVX_DESC= Support Advanced Vector Extensions (AVX)
.if defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT= DYNAMIC_ARCH
@@ -87,7 +87,7 @@ BROKEN = QUAD_PRECISION is broken; please disable this option
BUILDFLAGS+= QUAD_PRECISION=1
.endif
-.if empty ( ${PORT_OPTIONS:MAVX} )
+.if ! ${PORT_OPTIONS:MAVX}
BUILDFLAGS+= NO_AVX=1
.endif